0

I have a wordpress website set up for a company on domain.com, with a contact form. The company already has mail set up on gmail, info@companyname.com. I want the contact form to send mail to the company's gmail. I have done several things:

  • The contact form is configured to send from: domain@domain.com (default email address for my domain?) to:info@companyname.com
  • The website is hosted on cPanel. From the cPanel hosting dashboard, I have set the MX entry records to Google Apps MX record values and set email routing to remote mail exchanger (which I assume means it will not handle the mail locally, but send it to the records above)

  • After doing so, mail was bouncing back at domain@domain.com webmail with the error message: No such user : info@companyname.com

Completely clueless as to what is the usual procedure to going about achieving this (simply getting a contact form to send mail to gmail, a different server). There is also an option on cPanel hosting to setup an email forwarder - not sure if this is the way to go. Any help/explanation?

  • Did you try sending a mail to info@companyname.com to verify if the inbox exists? – Prasad Ajinkya Jun 18 '16 at 3:45
1

Have you verified info@companyname.com actually exists by sending email from domain@domain.com using a browser or client? You can verify DNS settings in the google apps admin dashboard. If the mx records are not set up correctly then you will need to fix that issue first.

If email does exist, then the best way (maybe not the easiest way) I have found to send emails from clients website is to setup a mailgun account on a subdomain of yours, something like mg.domain.com and configure the required DNS entries.

Once mailgun account is setup and verified you can install the mailgun WordPress plugin and use the http api. You can then configure the form to send emails from domain@mg.domain.com to info@domainname.com.

I have had zero problems using mailgun to deliver emails from multiple subdomains to multiple different gmail accounts and gapps accounts. It is now my default configuration for forms requiring emailing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.