3

The situation is:

I have a domain, let say it is: mydomain.com. is was configured to manage its own mail, there are several e-mail accounts configured on it.

a@mydomain.com, b@mydomain.com, c@mydomain.com, etc.

this worked.

now I wanted to use some of the features of Google Apps for Work for my domain: mydomain.com. So I setted up a Google Apps for work account: administrator@mydomain.com

(this account is registered directly into Google Apps for Work , so on the actual domain: mydomain.com there is no such account as administrator@mydomain.com)

I did successfully verified my domain: mydomain.com on the administrator@mydomain.com account, so this account and my domain are connected.

Now here comes a bit of a tricky thingy:

  • I have a administrator@mydomain.com Google Apps account with Gmail.
  • I have a bunch of email addresses on domain: mydomain.com (a@mydomain.com, b@mydomain.com, c@mydomain.com, etc.)

Now i have to configure the DNS on mydomain to be able to communicate with:

administrator@mydomain.com <-- send/receive --> mydomain.com, etc.

DNS Settings:

  • option 1: keep the original DNS settings, just let it manage email traffic by itself. Result: a@mydomain.com etc. can´t send mail to administrator@mydomain.com. because administrator@mydomain.com is unknown/not existing on the domain mydomain.com.

  • option 2: add the Google MX DNS records. Result: a@mydomain.com can send mail to administrator@mydomain.com but administator@mydomain.com cant send mail to a@mydomain.com etc. because the address(es) are unknown

(because they these addresses configured on mydomain.com, and we just told it to hand over the mailing responsibility to the Google mailing servers by setting the the MX records)

  • option 3: (experimental, not sure if valid) add the Google MX records and keep the original MX record.

I tried all of the above options but i wasn't able to achieve the following:

  • send/receive mail from/to administrator@mydomain.com and a@mydomain.com.
  • send/receive mail from/to a@mydomain.com and b@mydomain.com

Is there a way how to achieve this?

Note: I only want to use the Gmail environment for the user: administrator@mydomain.com. the other accounts like: a@mydomain.com can still use there webmail client.

Maybe somehow like this:

Allow third-party MX records in the DNS and prioritize these so that if a email account is unknown at the Google Mail server just go check the original mail server. (you can prioritize MX records AFIK but that is just in case of unavailability)

But even if possible, how?

i realize this might be impossible because Google would like you to import the email addresses directly into Google Apps environment. But by doing this I have to create extra users, and for every email/user-account i create i have pay extra...

is there a way to fix this? and what is there is no way this would work.. what do you suggest me to do? =)

1

is there a way to fix this?

Unfortunately not.

SMTP email protocol just doesn't support it. A server sending email to you asks your domain's DNS server for MX details. You can have multiple MX records but they are for load-balancing/availability, not for individually named email recipients.

Google Apps for domains(GAFD) assumes you will move ALL email accounts to their service. Trying to get around that is likely to lead to unexpected and officially unsupported behavior.

and what is there is no way this would work.. what do you suggest me to do? =)

If you are not willing to pay for the service I would suggest carefully examining which features of GAFD you need and sourcing them from somewhere else.

1

If you are trying to use the Google Apps for a trial or for just some things unrelated to emails for your company/domain , I would recommend you to create a sub domain and point the mx records to them and proceed testing/using the account.

Eg: you can create administrator@uk.mydomain.com and verify it, and proceed.

There is no way to perfectly receive emails on both the mail exchange servers at the same time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.