0

After many months and many changes to sitemaps/pages trying to solve the problem, Google still is not indexing the product pages of this site (link removed). Here's the sitemap i'm using (link removed) , use view source to see it better.

The pages i'm having problems with are the ones with the product IDs.

Like /wp/product-en/?ID=14 and /wp/product-it/?ID=14. I've added the ID parameter to the URL parameter section in the Google Search Console with settings:

  • "Yes: changes,reorder or narrow page content" ;
  • "Select";
  • "Let google bot decide" (i've also tried with "Every URL" but it doesn't make a difference);

Now, if i search the URL in the Google Search Console i get different results, for example:

  • /wp/product-en/?ID=21 says "Discovered – currently not indexed";
  • The /wp/product-it/?ID=21 version says "URL is unknown to Google" even if it's in the sitemap;
  • The google explanation says "Discovered - currently not indexed: The page was found by Google, but not crawled yet. Typically, Google tried to crawl the URL but the site was overloaded; therefore Google had to reschedule the crawl. This is why the last crawl date is empty on the report."

But honestly it's odd to think that's the problem for every single product page. The ID is used to select the image and description of the specific product from the DB.

Any ideas why the product pages are not indexing?

Thanks in advance.

0

Sitemaps really are a thing of the past, and while Google does scan them, links to pages for links seem to be Google's primary means of identifying content worthy of being indexed. See Sitemap paradox

It could simply be that you don't have any pages with links to these "non indexed" pages other than your sitemap and therefore Google doesn't place enough value on these pages to index them.

Lastly, you should read Why aren't search engines indexing my content?

| improve this answer | |
  • That... doesn't make sense per se, but it explains why the pages are not indexed. I use an intermediate link to pick the page language, so the direct link to the product isn't actually in any page. I'll try to bypass the problem and get back with the results. Thanks for the input! – JacobTK Aug 28 at 19:38
  • Yes, that was the problem, now the site is indexing correctly, thanks a lot! – JacobTK Sep 4 at 5:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.