2

First, let me say that Shopify couldn't figure this out, nor people I tried to hire on Fiverr.

My site seemingly, and for no apparent reason, got messed up on Google. My traffic went down to 0 and the culprit is Indexing.

  1. Google console suddenly says that my main domain's URL is not on Google.
  2. On Bing, I am able to get indexed with no issue
  3. In Mobile-Friendly Test it says that "Page cannot be reached" (however I am able to see the site on mobile)
  4. On Google's pagespeed test, it gives a lighthouse error. (screenshot attached)
  5. When trying to request indexing, I get an error "Indexing request rejected"
  6. When re-submitting the sitemap (that was always fine in the past) it can't be fetched. (There is no problem with the sitemap and it exists on the site) Console says "sitemap could not be read - General HTTP error"
  7. Console says that site might be blocked by robots.txt but I checked and the site is NOT being blocked there (and the file exists on the site)
  8. I have no removal requests for pages on my site.
  9. I am a verified owner of the site.
  10. I did not remove the HTTP property.
  11. When trying to test robots.txt, I get the error "robots.txt fetch failed

p.s. I used the new "DOMAIN" section when adding a property, which includes both HTTP and https (i.imgur.com/oCgAvZa.png). Anyway, I also added https and by default, Shopify will direct HTTP to https and that's why in console, you see by https is says "redirected." I have the exact same issue in the HTTP property.

Attached are some screenshots. Any help would be greatly appreciated.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

  • It appears you have CloudFlare enabled on this site. Have you tried testing it without Cloudflare by pausing it and entering Development Mode to bypass caching? Is the last screenshot of your site's code (it would be helpful if you labeled them)? Obviously the noindex instructs Google specifically not to show this page in its search results – dan Sep 4 at 5:43
  • Your site isn't working when tried on my browser. Is the server up? – Kannan Sep 4 at 5:56
  • @dan Shopify uses Cloudflare and I can't disable it. I removed the code screenshot. That noindex is my custom one that I use for a few pages that I don't want indexed (for example: {% if handle contains 'thank-you-20' %} <meta name="robots" content="noindex">{% endif %} This code has always been there and didn't cause an issue. – Zvi Twersky Sep 4 at 5:59
  • @Kannan What is the url that you are typing? did you try crayolex (.com)? I have no problem accessing the site on PC and mobile and I used VPNs to test as well. What Country are you from? – Zvi Twersky Sep 4 at 6:00
  • 1
    @ZviTwersky I think you meant to direct that comment to Kannan - I didn't comment that it wasn't reachable, Kannan did. – dan Sep 4 at 7:50
2

Solved! You were all right, just Shopify support figured out exactly the problem.

In my DNS, I had added 5 A records of G-Suite which I should not have. You shouldn't have A records pointing to two places. Also, my CNAME was crayolex.myshopify.com and it should have been shops.myshopify.com

Now the site should load for everyone else. And, the Google Console is indexing the site. I will now fix sitemap, coverage, and anything else. Before I couldn't do anything, was just getting errors.

enter image description here

| improve this answer | |
  • 1
    Glad you solved the issue (I think you meant Kannan by the way). Please accept your answer when you can. – dan Sep 4 at 8:28
  • 1
    No, I meant you. You wrote, "If you figure it out (like its related to Cloudflare), please add that as an answer below and accept it." I'll accept my answer when the platform allows me; in two days. – Zvi Twersky Sep 4 at 8:52
  • Great, glad I was able to help then :-) – dan Sep 4 at 9:11
1

The website is blocked on other users network because you are not using correct implementation of https.It not your firewall, its their networks. You have https enabled but it might be an implementation issue from your dev team end.

Three types of security symbols browser shows:

Secure Secure

Info or Not Secure Info or Not Secure

Not Secure or Dangerous Not Secure or Dangerous

Your website is showing second issue. It might work or it might not on other networks.

You need to delete your http version and redirect all the available instance of the url to https or preferred https version and then submit it again to the Google webmasters. Before submitting it again:

Check your .htacess
Check your robots.txt
Check your sitemap urls (do not submit different version of sitemap)
Check your domain versions (http or https, www or non-www, with "/" or without "/")

As I have investigated you website is accessible with https://crayolex.com/index.html also. It means you are giving search engines to reach your website more than one path.

Also you need to check on Google webmasters where you are submitting the website:

There are two available option on Google webmasters, please check the screenshot. screenshot

| improve this answer | |
  • I had already checked their SSL and there's no issues with it. There's also no indication of insecure content, there's already a redirect to HTTPS occurring, and the OP stated above in the comments that they're using the Domain property type. So although these are common issues, they really don't apply here. – dan Sep 4 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.