1

I have a Wordpress website using WooCommerce, but my shop pages are really slow because it takes a very long time before my product thumbnails start to load. The page loads fine up till the moment that the product thumbnails (600px x 600px) should be fetched...

I have optimized these images & I'm using WP Rocket as caching plugin. However, in my example below, it takes about 67 seconds to load a page with only 5 thumbnails, which is really unacceptable.

Any idea on how to enhance my WooCommerce loading performance? I have attached the GTMetrix report, where you can see the waterfall diagram. There, you can see there is a long pause before the product images start to load. It's this pause I'd like to remove, but I don't know how...

Any idea?

  • Ok, so I think I have a clue. I have used a shortcode for Gravity Forms in the field which is my product description. I have disabled the product description excerpt on the product list pages, but it seems in the source code however, this Gravity forms shortcode is rendering in background. Every product has a shortcode behind it, so an enormous amount of Gravity Forms is rendered taking a very long time... – BarrieO Oct 27 '17 at 11:48
  • does this pause always happen before the images? You might want to check the webserver logs (example access_log if you're using apache) to see what's going on. Its likely that others are requesting content at the same time which creates the pauses and/or the web browser you are testing with isn't optimized either. – Mike Oct 27 '17 at 17:45
1

Solution here: https://wordpress.stackexchange.com/questions/284164/remove-product-description-from-product-archive-page/284171#284171

This was related to the template I was using, so not really webhost related.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.