I've not set up a home web server before so chances are I've made many mistakes.

I've used XAMPP on the pc, set up the name servers, used freedns and so far so good. The site is visible, online and going well, or so I thought.

My next step was to configure the IDE to upload files automatically when changed. FTP has been set up and is working perfectly, When I connect and upload a file, it shows on the web server.

The problem I'm having is that these new files are only visible from the machine that is hosting the site. I've tried copying and pasting (on the server) and get the same result.

Can anyone explain what the problem might be please?

To summarise (apologies for rambling): Uploaded files to server are being uploaded fine but are not visible when accessed from any machine other than the web server. As a test I created a new file when using the web server and the same result is received.

Any help is much appreciated

::Also:: I've read that XAMPP is not best for security. If anyone can point me to an idiots guide for how to do it 'properly' I'd be very grateful :)

  • How exactly are you trying to access the files? http://example.com/myfile.php? Are you using local DNS to resolve the domain or external DNS?
    – MrWhite
    Sep 1, 2013 at 13:57
  • @w3d To access I'm using steve-t-green.com/albums/1.png. Another issue I'm having is that the www prefix doesn't seem to work. I do't think I'm doing anything local with DNS, freedns is the only place where I've updated those details. ---Now, I can access the site fine on my laptop, even after clearing cahce yet partners laptop can't open the site. -.-
    – null
    Sep 1, 2013 at 14:10
  • Is your laptop and your partners on the same LAN? The webserver is on another machine on your LAN? And you are accessing the webserver via the external IP of your LAN? Not internally?
    – MrWhite
    Sep 1, 2013 at 21:23
  • @w3d, Hi, yes they're on the both lan. Trying to access the site via url instead of ip. As of earlier this morning the site is now live but only witha /website in the url - please see answer below. I tried adding the /website to the doc root but receive an access error message
    – null
    Sep 2, 2013 at 20:07

1 Answer 1


I'm sorry to inform you, but your steve-t-green domain loads an Index of / and within it it's your website/ directory.

Therefore to access your photo I added that directory in the url like this: http://steve-t-green.com/website/albums/1.jpg

Not to mention it's a jpg, not a png.

Also, you might want to configure the apache/conf/httpd.conf file and add "/website" in DocumentRoot.

  • Hi, It working with without the "/website" is the most recent update. I wasn't expecting anyone else to view or reply to this question anymore. After a few hours the site works. I added the /website to the dir in http.conf but it then shows access forbidden when trying to access the site. Currently the only way to view it is to go via what you wrote. Any ideas why?
    – null
    Sep 2, 2013 at 20:05
  • @SteveGreen: "access forbidden" - do you have an appropriate DirectoryIndex set? (Maybe you only set this in the parent directory's .htaccess file, which is no longer accessed?!)
    – MrWhite
    Sep 2, 2013 at 21:01
  • @w3d - I think I have. This is my http.conf. I think we're ignoring the htaccess for now until we were able to find out what the problem was. This is my http.conf pastebin.com/jDyyDhHe The structure I'm using is having c:/www as the global folder for all sites with my personal one being in the website folder within www The XAMPP admin stuff is still located where it was installed, in c:/Server. I've added a vhost so that I can still access it from the local machine. I always miss your messages. If you could help and don't mind throwing me an email its [email protected] Many thank
    – null
    Sep 3, 2013 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.