2

We recently are experiencing issues where our website is taking over a minute to load and when looking into the webpagetest results to see what can be causing the issue, a new (we believe it to be new atleast) thing that is displaying and being the clear culprit is after loading the domain, it goes into loading gstatic.com/generate_204 which almost appears to time out everytime, then everything after that loads in.

enter image description here

enter image description here

The CPU utilization seems to be fluctuating the whole time as it tries to load as well so something is going on, I am just not sure exactly what. (The generate_204 may not even be the issue, but it does appear new as we run tests all the time and looks to be whats causing the issue in our eyes)

enter image description here

I am unaware of what this generate_204 is, and when googling it, you see a lot of it being a type of malware or similar that you remove from your computer, but this seems to be on my website (maybe within the files) that is now suddenly trying to load on all pages and destroying its load time.

Does anyone know what this may be, how we could possibly find it and remove it? -- And if this may not be the problem, any ideas on better ways to determine the possible culprit?

For reference, the website is a Magento webstore. Thanks!!


UPDATE in response to @Trich's comment;

After running the same webpagetest on a firefox browser, it had the same delay but a different trickle down loading sequence;

enter image description here

Looking into what the http://website.com/.well-known/http-opportunistic could be, it appears those are security measures my hosting company has put in place?

Other than that, everything else looks the same with the same extreme long delays... So my next only thought would be to start disabling extensions one by one to try and see if one may be the culprit with my Magento store? (Even though I haven't added much new modules in a while)


Latest test going directly from HTTPS;

enter image description here

1 Answer 1

2

It's a connectivity checker in Chromium products (Google Chrome and other browsers based on Chromium) that tries to confirm whether the user has full internet access.

As the name suggests, it generates a 204 status code ("no content") in response. If any other response is given, it's assumed that the user has restricted internet access. It's usually from a guest wifi connection that requires authentication or, less likely, a mobile connection from a user with no data allowance (on a mobile plan that doesn't automatically charge for extra data). And possibly other reasons.

Having said that... I don't know why it's called from your website, and it's strange to see it called so early. Which Google services do you use on the site? Analytics? Fonts? Anything unusual? Possibly something in a Magento plugin you're not aware of?

First thing I would do is access the site from a non-Chromium browser. Try Firefox or Safari and check the load time of your website.

Next, do some more WebPageTest runs using non-Chromium browsers (default test uses Chrome).

10
  • Thanks for the quick response! I ran a test in a firefox frame and posted the results in an edit to the original question. Any ideas?? Thanks!
    – ne0nlight
    Feb 17, 2021 at 20:44
  • Are you submitting the HTTP or HTTPS address for testing? It looks like HTTP is entered, which 301 redirects to HTTPS. ".well-known/http-opportunistic" is related to opportunistic encryption, but the timing on that looks fine (from what I can see) and it's actually the switch to HTTPS that comes next which is causing the huge delay. I tested one of my sites by entering the HTTP address for testing and it 301 redirects through http-opportunistic and lands on the HTTPS address within 300ms, so there's something else happening with your site. Try disabling opportunistic to test?
    – Trich
    Feb 17, 2021 at 21:10
  • I was submitting the original HTTP, so I tried again on FireFox with the direct to HTTPS test, and it continued the long load where it displays the first connection being the longest (shown in new Edit to main post) -- oddly enough, the second entry is to ocsp.sca1b.amazontrust.com which I have no idea what that is, nor do we have anything on that store connected to/wanting to be connected to amazon. Is this indicative of some foul play at hand?
    – ne0nlight
    Feb 17, 2021 at 21:38
  • Amazon Trust is a Certificate Authority. If you're not hosted on Amazon Web Services (AWS), maybe your HTTPS certificate is related to Amazon somehow? (Possibly via third party). It's hard to say for sure, but it looks like there's something very wrong with your HTTPS certificate or they way it's implemented. Try using "openssl" either from your PC or on the server itself. There are tutorials about troubleshooting HTTPS with that.
    – Trich
    Feb 17, 2021 at 21:56
  • Hmm, the interesting part about that is that we use the free Cloudflare SSL/TLS encryption with it set to "Full - Encrypts end-to-end, using a self signed certificate on the server" ... Could this be a Cloudflare issue I would have to raise with them?
    – ne0nlight
    Feb 17, 2021 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.