I have the following problem: I cannot submit any sitemap recently to Google Search Console.
Let me give you an example: https://ru.azrhymes.com/static/sitemaps/ru/sitemap-main-1.xml.
(validator says ok)

And Google says "Sitemap could not be read" explanation: "General HTTP error".
I also tried sending in .txt format sitemap that complies with google specifications (one url per line), yet still the same result: "Couldn't fetch".

What am I doing wrong?
(I'm using nginx.)

  • You don't need to submit a sitemap. It won't hurt your site in any way not to have one. Feb 24, 2020 at 17:06

2 Answers 2


You may not be doing anything wrong at all.

"General HTTP error" can mean many things.

The Internet/Web is not a guaranteed delivery protocol. Things will go wrong from time to time. This is not uncommon even for Google.

If you can access the sitemap yourself, then be patient. Many of us have experienced Google having trouble reaching our resources or pages periodically and it could take a few days before Google does have access.

As a side note, the tradition is that sitemaps are in the root of the website as sitemap.xml. I am familiar with creating one index sitemap and additional sitemap files for large sites but not familiar with providing sitemaps for different languages. I do get what you are doing. Google will try and find a site map in the sites root directory from time to time and why I mention this at all. Perhaps you can take advantage of this fact.

  • Thanks for your answer, @closetnoc, it turned out that something was wrong with serving the robots.txt and google misinterpreted it, so it might have thought it was disallowed to take a look at the sitemap index. Feb 25, 2020 at 2:15

This may be a variant on the answer above, but the link here is to a Google Support discussion that is on point Sitemap index processed but Google couldn't fetch sitemaps

We tried submitting our new sitemap in the search console: The page links to 4 sitemaps. While Google says the "Sitemap index processed successfully", it "couldn't fetch" any of the 4 sitemaps

The answer posted for that question:

Frankly it's mostly like bug. The new console sometimes shows 'Pending' as 'couldnt fetch' incorrectly.

... its normal for sitemaps to be 'Pending'. It can be hours, it can be weeks, in Pending. It varies by sitemap.

But first need to check if there REALLY is some sort of Fetching issue. ... the 'Live Test' function inside URL Inspection can be used for this.

Try Inspecting the sitemap URL itself, then click the 'Live Test' button. See what it reports under 'Page Fetch' (in 'Crawl' section) - ignore the messages about Indexing!

The reason I am posting this is that as of March 26, 2023, I am having the same problem, i.e., I just correctly placed a sitemap in xml (handcrafted) and it passes the Live Test in Search Console, but still showed a red "couldn't fetch" error under Sitemaps status. As I write, about an hour after this, I just checked back and now Google has changed the status of the sitemap to green "Success."

So it may be useful for others encountering this problem to use the Live Test as described and then try to wait patiently until Google gets to it, ignoring the red "couldn't fetch" (and not trying to index the sitemap also).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.