4

I am asking for help with the following problem:

I own a website in Google Search Console (as pe.kmec@gmail.com, along with another owner):

Screenshot 1

Later on I logged in under my company's name, created a Google Search Console account under my company's name (kopexsro@gmail.com) and verified kopexsro as the owner of the same website via a HTML tag:

Screenshot 2

Under pe.kmec@gmail.com I correctly see the search history of the website with any time window. However, under kopexsro@gmail.com the search history is stuck in the past few days (even though I select "last 3 months"), see screenshot:

Screenshot 3

Then, I switched to the pe.kmec@gmail.com account and added kopexsro as another owner (i.e. delegated ownership):

Screenshot 4

However I still see no traffic under kopexsro.

Could it be because kopexsro was originally added independently of other owners?

And when I delegated the ownership to kopexsro could it be that the "delegated" kopexsro somehow is not recognized as the "original" kopexsro?

  • 1
    How long has it been since you logged in under your company account? – zigojacko Nov 30 '18 at 9:54
  • I did the verification for kopexsro@gmail.com 3 days ago - 11/26/18 2:05:28 PM UTC. I delegated ownership to kopexsro an hour ago. – runnerup Nov 30 '18 at 10:16
  • 1
    I would suggest leaving it for a week or two to see if you start seeing the same data under both accounts. Google Search Console is notorious for not showing 'up-to-date' data. – zigojacko Nov 30 '18 at 10:50
  • Thanks Tony, now it works - I added the the property without 'www'. – runnerup Dec 13 '18 at 8:48
3

Your screenshots show different sites. Some include www, and some don't. The difference of www means a different site, and different performance data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.