2

My website http://bakasura.in works fine. when i try to visit it via www.bakasura.in it doesnt work.

What is the problem ?

  • Looks like an interesting name to me. – adarshr Feb 24 '11 at 9:33
6

You need to look at your DNS configuration.

www is not automatic, and needs a manual (A?) entry or some kind of wildcarding.

  • 1
    preferably A and AAAA (or just a CNAME) – awoodland Feb 24 '11 at 9:33
  • Might be an idea to check that the website in the iis has an identity of www.bakasura.in mapped to it too. – Luke Duddridge Feb 24 '11 at 13:29
2

This is not rare. They configured their webserver "wrong" by not setting their standard-entry and web-server-entry to the same service. This is something they can decide for themselves by e.g. changing a config file in their e.g. Apache.

  • I'd go about fixing the DNS records first, which is not an apache setting! – awoodland Feb 24 '11 at 9:35
  • 1
    @awoodland: Actually, both are necessary - but since DNS records can take some time to propagate, you are right that they should be changed first. – Piskvor left the building Feb 24 '11 at 9:40
  • It's perfectly possible (and even reasonably likely) that the apache config is correct. You can even test this by sticking a line in /etc/hosts or wherever the windows version of this file lives to simulate the missing DNS record and verify that it is indeed only a DNS problem. – awoodland Feb 24 '11 at 9:49
1

As everyone else has said i would double check DNS and then look at your web server config to make sure its set-up to respond to both.

One thing i would think about from and SEO point of view is which you want to be your main indexed URL as really you want people to find and bookmark etc by one address and stop duplicate content issues. The best solution is to 301 redirect the non primary version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.