1

When I try to open my site on IE (development, environment, or online), it crashes every time. This is my server readout upon entering the home page (it actually crashes on any page view after this):

Rendered shared/_footer.erb (0.0ms) Rendered welcome/index.html.erb within layouts/index (179.0ms) Completed 200 OK in 204ms (Views: 203.0ms | ActiveRecord: 0.0ms) [2010-10-24 03:16:26] ERROR Errno::ECONNABORTED: An established connection was a borted by the software in your host machine. C:/San/Ruby192/lib/ruby/1.9.1/webrick/httpserver.rb:56:in 'eof?' C:/San/Ruby192/lib/ruby/1.9.1/webrick/httpserver.rb:56:in 'run' C:/San/Ruby192/lib/ruby/1.9.1/webrick/server.rb:183:in 'block in start_ thread'

Another error I sometimes get:

[2010-10-24 03:22:21] ERROR Errno::ECONNRESET: An existing connection was forcib ly closed by the remote host.

Do you know what the problem might be? This is crucial for me because of the people who may be using the app. Thanks everyone.

Setup:
Ruby 1.9.2
Rails 3
Servers: Webrick for development, MySQL for production (failure occurs equally on both)
Host: Heroku

2

without knowing anything more about your site, I would say, you have a similar problem as described here. The main idea behind this bug is, if you modify some DIV or other kind of HTML-tags with JavaScript, before they are closed, IE says 'Operation cancelled...' and will not load the page.

I would suggest that you disable JavaScript for testing. If IE doesn't crash, you can be sure, that you are having problems with your scripts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy