1

On my magento 1.7 site, the images aren't visible on Google image search. When I search for site:example.com, I find mostly PDF images and pictures from videos.

PDF-youtube image

How do you configure Magento to for google image to index only the images shown in the HTML?

  • i found a majority of pdf image and picture video. This implies that your images are being found, which I found also, and that you may not want images from PDFs and videos. Is that right? – closetnoc Oct 23 at 15:21
  • site: searches in general don't order things in any useful way. I expect you would like to see your important images first, but Google chooses to order things to make it hard for you to figure out what they think is important. – Stephen Ostermiller Oct 26 at 17:51
  • Hello, my site is not new and I use the ALT for SEO. I do not understand why my images are not referenced (apart from that of my pdf and thumbnails of my youtube videos that are on my pages). I just made the site: website.com to show you my example. I think I missed a magento configuration. It's more the solutions I'm looking for right now. I added the photos in the sitemap. I hope it will solve my problem. – ColoO Oct 28 at 13:11
-1

Just start use alt and title for the images you want to have indexed.

More tips: https://yoast.com/image-seo-alt-tag-and-title-tag-optimization/

  • 1
    I'm not sure this will solve the problem. It isn't that the images are not getting associated with keywords. They are not doing an keyword search, they are doing a site: search. I don't think that using alt and title is going to change the order of the images in a site: search, nor is it going to prevent the PDF and video images from getting indexed. – Stephen Ostermiller Oct 26 at 17:49
  • 1
    In general, such a short answer is not considered high quality here. When you answer here, it would usually be better to write few full paragraphs. – Stephen Ostermiller Oct 26 at 17:50
  • Hello, my site is not new and I use the ALT for SEO. I do not understand why my images are not referenced (apart from that of my pdf and thumbnails of my youtube videos that are on my pages). I just made the site: website.com to show you my example. I think I missed a magento configuration. It's more the solutions I'm looking for right now. I added the photos in the sitemap. I hope it will solve my problem. – ColoO Oct 28 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.