1

I've been fighting the Google canonical page algorithm bug for 2+ months. Following various forum advice and suggestions haven't solved it yet, although for sure they've made our website better. One advice I've been given is to hide, or make silent, our use of a page generation Perl script, and give Google indexing only "plain URLs" with no script, no page parameters, no file extensions, etc. I don't know if that fixes it but anything is worth a try when Google indexing goes into lock mode and refuses to index your pages.

My question is: how to start with a URL and end up with the same URL, with Perl script processing in between? I thought about doing it with an .htaccess rewrite, which we already use, for example:

https://www.example.com/abc --> https://www.example.com/gen.pl?p=abc

but then I would need to rewrite back, and that would be an .htaccess loop. Plus if the gen.pl URL were given in the first place I would not want the first rewrite.

Any and all suggestions on how to solve this welcome.

  • Was Google reporting any errors in GSC? I can't see that changing your URLs is going to help - there is nothing "wrong" with your existing URL structure (as far as the search engines go) - so the problem is likely elsewhere. If Google is picking the wrong canonical page then it's generally because of content, not the URL? Changing the URL structure is not without it's own problems and could itself result in a (temporary) SEO hit. In order to change the URL structure, you obviously need to first change the URLs throughout your entire site - is this something you are prepared to do? – MrWhite Jun 10 at 23:03
  • @MrWhite, no errors on GSC. No page redirects, mobile friendly. The GoogleBot is just unable to canonical its way out of a paper bag. I don't think content is the issue either, for example this page (signalogic.com/codec_samples) is a very large, unique page. It used to bring in 100s of clicks for us every day. There is nothing else even remotely close to that on our site. Now I cannot get it indexed for the life of me. Re. underlying page structure, no not prepared to change it entirely; that's why my question. – Jeff Brower Jun 10 at 23:11
  • I don't think it's necessarily a canonical issue. That page simply isn't indexed (as you state). Canonicalisation still requires all the pages to be indexed - it's just that you are setting a preference for which page (from very similar pages) is returned in the SERPs. A site: search should still return the non-canonical pages - in your case it doesn't. A site: search for the title on that page returns another page that links to that page, but not the page in question. – MrWhite Jun 10 at 23:56
  • I can't see an obvious reason for this, except that you do have a lot of XHTML validation errors (your page is not XHTML) - you would see a great improvement in "validation" at least by simply switching the DOCTYPE to HTML5. Although I would not expect this to be the reason why Google would drop the page entirely. Have you tried a "Fetch and Render" in GSC? Curious, you linked to /codec_samples, which 301 redirects to the .pl URL - do you use these "pretty"/redirect URLs elsewhere? And you mention .htaccess, but your site returns an Nginx header - is this just front-end proxy? – MrWhite Jun 11 at 0:08
  • @Mr White, GSC specifically says "Duplicate, submitted URL is not selected as canonical". If you search "codec wav samples site:signalogic.com" the page is not found or referenced, even though other indexed pages link to it. The forum link I gave in my question clearly describes a canonical algorithm issue. Unfortunately, like some of the larger outfits discussing the problem on that forum, I can't pick up the phone and ask Google to fix it. Thus my original question -- maybe avoiding a URL format that even remotely looks like e-commerce is a way around the problem. – Jeff Brower Jun 11 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.