8

My brothers site that I designed for him awhile has hundreds of SOFT 404's reported in Google's Search Console formerly Webmaster Tools. Generally I find fixing soft 404 easy but this has me a little stumped. All the soft errors are returning a odd string that contains Q82019309.com with the occasional sub folder Aristocratwithin the string /?=.

The 404's generally look something like:

  • Encoded: /search/%E5%A4%A7%E5%A5%96%E6%80%BB%E4%BB%A3Q82019309.com
  • Decoded: /search/大奖总代Q82019309.com

The linked from information provides:

  • Encoded: /?s=%E5%A4%A7%E5%A5%96%E6%80%BB%E4%BB%A3Q82019309.com
  • Decoded: /?s=大奖总代Q82019309.com

At first I believed this was an isolated issue but upon investigating I discovered that this issue actually affects thousands of websites and someone must know the cause. When I Google Q82019309.com WordPress or Aristocrat Q82019309.com I'm overwhelmed with the amount of results, including some of highly reputable sites such as:

Question(s):

So what is causing these soft 404 errors with string Q82019309.com with or without Aristocrat.

  • Your site has been hacked. Q82019309.com is compromised. – closetnoc Jan 20 '17 at 19:04
  • Going to the site Q82019309.com says its an attack site and I agree that its dodgy but I find it hard to believe that all these sites have been hacked with something that uses a query string in the search. There is literary hundreds of thousands of websites that are reporting Q82019309.com... highly reputable ones... surely these are not all hacked? – Simon Hayter Jan 20 '17 at 19:12
  • The links appear to be all spammy. A very typical profile. As well, this seems to be specific to WP sites. This seems to be fairly recent, within just a few days (4 or so). Check the WP install to make sure everything is up to date. See: web.nvd.nist.gov/view/vuln/… – closetnoc Jan 20 '17 at 19:23
  • Was discovered over a week ago 13th. – Simon Hayter Jan 20 '17 at 19:29
  • Think I'll have to look through the errors.log and access.logs to identify if someone has attempted or got in via a new hack. – Simon Hayter Jan 20 '17 at 19:36
2

We were having the same issue at wisepops.com since the 3rd January 2017.

Google is complaining about Soft 404 even if indexing is disabled on these pages. The Wordpress search page has by default this meta:

<meta name="robots" content="noindex,follow">

I decided to make search pages without results return a 404 HTTP code. Since the search query is in the URL, it is fine to handle it this way.

For Wordpress, I added at the end of my theme's functions.php:

/*---------------------------------------------------*/
/*  SEARCH PAGES WITHOUT RESULTS SEND 404 HTTP CODE  */
/*---------------------------------------------------*/
function wisepops_search_404_code() {
    if (is_search() && !have_posts()) {
        header($_SERVER['SERVER_PROTOCOL'] . ' 404 Not Found');
        $GLOBALS['wp_query']->is_404 = true;
    }
}
add_action('get_header', 'wisepops_search_404_code');
  • @wisepops.com: I have the same problem with this stupid Search-Spam Attack. Thank you for the code! It worked great for me! Now empty search returns a clean 404 and that's cool. Sincerly, Mitschu – Mitschu Feb 4 '17 at 18:11
  • Would this send an actual user that makes a search and gets zero results to a 404 page as well? – brandozz Mar 9 '17 at 21:31
1

It looks to me like your something is linking to your site search functionality with bad queries. Those search queries get "no results found". Googlebot is finding those links and you are allowing Googlebot to crawl your site search. Because of the "no results", Google is detecting them as "soft 404".

Letting Google crawl your site search results is a big no-no. It can get your entire site penalized by Google. See Matt Cutts: Search results in search results. You should disallow all crawling of search results using robots.txt:

Disallow: /search
Disallow: /?s=

Then Googlebot will not crawl those URLs and report errors there either.

  • Stephen, did this reslove the soft 404s? I've actually added this to my robots.txt and marked all of my soft 404's on the search page as fixed. Once I verify, I'll mark this as correct. But this seems to be the best solution. – brandozz Mar 9 '17 at 22:18
1

This plugin sorted the problem for me:

https://wordpress.org/plugins/disable-search-slug/

protected by Community Apr 23 '17 at 13:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.