0

I have a client in Wisconsin that was previously hosting a website with excel.net--they also have internet through excel.net.

Because excel.net web hosting doesn't support PHP email, I migrated their site to hostgator, changed the DNS credentials, and the new hostgator-hosted website appears as expected everywhere--EXCEPT when accessed through an excel.net-provided internet connection. When a visitor on an excel.net internet connection loads my client's website, the old web site appears and typing the url for pages in the new website returns a 404 error.

I can no longer access the old hosting account by FTP and have changed the DNS credentials to the ones provided by HostGator. What loophole am I missing? How can I enable excel.net users to access the HostGator-hosted page?

And how can an internet provider alter DNS credentials for their users?

  • 1
    Who has the SOA (statement of authority) record? It normally should be the registrar. Sometimes if a host helps to register the domain, then it could be the host. You can do a dig example.com -any to see what comes back. Sometimes you will need to do a dig +trace example.com -any. This takes a while to return. That's okay. It will absolutely tell you who the SOA is. I am thinking that is what you are missing. Also, keep in mind many ISPs cache DNS records for a period. When using your ISP, if you are using their DNS, it will fail. Set your DNS to 8.8.8.8 on your PC and try again. Cheers!! – closetnoc Jan 5 '17 at 21:35
1

How long ago did you do this? DNS names can take up to 24 hours to update, maybe more.


My second best guess would be that excel.net is purposely doing this, you'd be surprised by what ISP's are allowed to do in terms of editing traffic.

The third option would be that there's an error on excel.net's side. They could be improperly updating DNS, or simply have a bug.

-

In any case, if it's been more than 48 hours I would contact excel and see if they know anything.

| improve this answer | |
  • So it was not the DNS, I had done this more than 24 hours ago. I thought your third scenario might be correct, so I called them twice to get tier 2 support to finally respond (yes!) and it turns out they continued hosting all the files on a so-called "backup" server and were rerouting the DNS. What idiots! So I had them take it down. It works now :) – sissypants Jan 6 '17 at 0:27
  • @Wagtail, if the answer solved your question, consider clicking the green x next to it. – Travis Jan 6 '17 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.