Hot answers tagged

29

First Step Open file as sudo vim /etc/apache2/apache2.conf Second Step remove comment sign (#) if you find it before this line ( line number 187 approx.) AccessFileName .htaccess Third Step Then find the line where there is <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory&...


8

The solution was located in digitalocean.com/community/articles/. I needed to perform the command: $ sudo a2ensite default-ssl


8

Here is the mod_speling documentation. The CheckCaseOnly directive does not enable the module on its own. You would need to both turn on mod_speling and also put in the check case only directive: CheckSpelling on CheckCaseOnly on When it is configured like this, mod_speling doesn't correct any spelling, it only corrects the case. This is a very awkward ...


7

Activate ModRewrite: sudo a2enmod rewrite sudo /etc/init.d/apache2 restart


6

To improve security, prevent host header attacks, and preserve your search rankings, here is what I recommend: No default site Simply drop all traffic not matching your genuine website. Before using the below config, execute the following example command on your server to generate self-signed "dummy" certificates which are necessary for responding ...


5

One of the biggest changes from Apache 2.2 to 2.4 is the way that permissions for directories are granted. The allow from and deny from syntax is now deprecated in favor of the new require syntax. See Upgrading Apache from 2.2 to 2.4. There is a module mod_access_compat that is supposed to allow you to still use the old syntax. Unfortunately, it didn't ...


5

This has to do with how Cloudflare connects to servers. Although it does serve the client via HTTP2 (or HTTP3), it still connects to the server itself via HTTP1.1. Cloudflare only uses HTTP/1.x between the origin web server and Cloudflare. https://support.cloudflare.com/hc/en-us/articles/200168076-Are-the-HTTP-2-or-SPDY-protocols-supported-between-...


4

This depends on how your network is setup. If you have a central DNS server on your network (as many enterprise business networks have) then you can add a zone record for whatever domain you wish for it to show up as. If you don't currently have a central DNS server you could set one up to achieve what you are after just the same. If both of those options ...


4

It looks to me like your server is set up to redirect to HTTPS, which causes a certificate mismatch error when a visitor tries to load one of these other domains that's pointing at your IP. This is a good thing, as reputable browsers and crawlers will see the certificate mismatch and know not to "count" the content in favor of the other domains, or ...


3

Create the remote connection To create a remote connection: On your database server, as a user with root privileges, open your MySQL configuration file. To locate it, enter the following command: mysql --help The location displays similar to the following: Default options are read from the following files in the given order: /etc/my.cnf /etc/mysql/my....


3

Doesn't matter what directory you run the command in, however it will save the sql dump file into the folder your currently in if using SSH to run the command. If you would like to save the file in an alternative path or should you be running it using a cron job then simply edit the last string with the full path you'd like to save the file too, i.e DBNAME &...


3

Your host name also needs to be added to /etc/hosts in 127.0.0.1 section. If you haven't rebooted since editing /etc/hostname you also need to set the hostname using the hostname command. This normally happens at bootup from /etc/hostname. Here is a script that I use to make sure the host name is set correctly on my Ubuntu ec2 instance: #!/bin/sh set -e ...


3

This appears to be related to a cluster of exploits that target fiber optic routers. If you are running a simple HTTP website and you are not maintaining fiber optic router equipment, I believe you can ignore those requests.


2

It is common practice to define a seperate logfile for each vhost. Without knowing your config, I assume, that the main nginx.conf has defined a default log file. It will log any request that is not matching any of the vhosts that might be configured. I assume that sites-enabled/mysite is a vhost that is using name-based virtual host (in Apache speech this ...


2

As this Ubuntu help document states: Setting up an email server is a difficult process involving a number of different programs, each of which needs to be properly configured. First you'll want to setup a Mail Transfer Agent (MTA), choosing either the default Postfix or exim4. This guide will explain how to install and configure Postfix. Next you'll ...


2

Check if you have the environment force-no-vary set to TRUE in your configuration, or simply try to set it to FALSE in your virtual host configuration. More details about this and how you should proceed, you can fine here: Environment Variables in Apache. Also, there are modules that may override this header when the response is served to the client - for ...


2

To get a website up at a domain name you need to follow these steps: Register the domain name. At the registrar, point the NameServer (NS) records to the domain name server (DNS) that will be handling the domain. On the name server, add records to resolve the host name to your server. Configure your web server to handle requests that come in for that ...


2

Credit to Harold Snel on Ask Ubuntu for answering this for me... He said: I had the same problem. With lots of Google-ing and trying I figured it out. You need to match what you setup in your virtual host with whats configured in the fastcgi.conf (of php-fpm.conf). Furthermore its beter to use '/fpm-status' and '/fpm-ping' in the /etc/php5/fpm/pool.d/www....


2

I've run into this issue myself, and would recommend not using apt-get and instead installing PHP according to the directions here from Parallels for Multiple PHP Versions in Plesk on Linux: Be sure to use the new version number of PHP for NN in the above so that you're installing and configuring it in a new directory and path for that version, and run the ...


2

You can check if your SSL is patched against the OpenSSL CCS vulnerability (CVE-2014-0224): sudo apt-get changelog openssl | grep CVE-2014-0224 If no results are displayed then your server requires updating! do the following: sudo apt-get update sudo apt-get install openssl libssl-dev sudo openssl version -a If you do get changelog results or both the ...


2

As mentioned in comments, I don't see any spurious redirects that you appear to be reporting and the two URLs do appear to return different content (although they "look similar"). So this appears to show different index.html documents, not the same? Not the cause of the current problem, but your redirection in your <VirtualHost *:80> containers is ...


2

Using putty terminal using SSH will automatically log you in with the top level directory structure while using FTP will be bound to whatever is set within your config. You will normally find public_html within /home/username or /var/www/example.com Other than that you can easily find the directory by viewing the FTP config and see what is being shared as ...


2

Nginx is a reverse proxy in your example, which means it terminates the HTTP exchange. Clients do not know that there is anything after Nginx, for them, Nginx is the webserver and the source of the response. As such the TLS handshake will also finish at Nginx and hence Nginx needs to have the server certificate and associated key to be able to properly set ...


2

Thank you, the QA here helped me to solve my issue. Here are specifics in case others run into similar issues with PHP "detection" incorrectly displaying the protocol behind a proxy such as Cloudflare. I found this Cloudflare SSL trick which would solve the issue for every php file executed. However, under a shared hosting environment I do not have ...


2

The problem is in a default configuration file that is included with Apache2 from Debian and Ubuntu: /etc/apache2/mods-available/alias.conf which has: # We include the /icons/ alias for FancyIndexed directory listings. If # you do not use FancyIndexing, you may comment this out. Alias /icons/ "/usr/share/apache2/icons/" You can comment out that ...


1

Thanks to w3dk's questions I was able to work through why my page re-directs weren't working. I was using let's encrypt for my security certificate, and because of (or perhaps my lack of knowledge), it created a new .conf file with the lines to load the ssl certificates (000-default-le-ssl.conf) which took precedent over the original default.conf. When I ...


1

My answer for NGINX was to create php-fpm pools for each site/virtual host. These pools each have their own user, and that use has no access to any files outside of the pool. So they are totally isolated. Here is an in-depth tutorial


1

Just create new account and install WordPress separately. Each WordPress site using separate database from phpmyadmin, so If your friends are not developer, then allowing FTP access is not good idea at all, they can do many things directly from WordPress dashboard.


1

Looks like a no brainer, folder ownership! Try doing the following: sudo chown -R www-data:www-data /webroot


1

OK Well looking at your setup, you want a htaccess redirect which is straight forward stuff. Remove all DNS level redirects at GoDaddy. If AWS is the main server that hosts the www.example.com then use the "@" a record entry as the IP of the AWS, this way non-www and www will work as intended. On the staging and development server enabled mod_rewrite so ...


Only top voted, non community-wiki answers of a minimum length are eligible