Hot answers tagged

5

You should encode the image name before giving it to crawl for any bots, i.e. the image name should be as %2F%D0%B7%D1%83%D1%80%D0%B0%D0%B3.jpg in your page source code. All modern browser decode it and for users will show the UTF-8 characters in a human-friendly way. So, do server-side encoding and encode all these characters before including in your ...


4

You can use the JkUnMount directive to prevent a directory from being handled by Tomcat. You can let the acme challenge directory be handled by Apache. The configuration for that might look like: JkUnMount /.well-known/acme-challenge/* * The final * should unmount it from all configured workers. If you want to exclude that directory for just one of ...


4

Convert your directory /var/projectA/static to a simple application: create a directory WEB-INF/ in WEB-INF/ create the file web.xml with this content: <?xml version="1.0" encoding="ISO-8859-1"?> <web-app> <servlet> <servlet-name>DirectoryListing</servlet-name> <servlet-class>org.apache.catalina.servlets....


3

I have given one hyperlink on webpage to access this file. When you provide the local path to a file in your webpages, as covered here, you're making the assumption that the file exists on the client's computer or device, not on your server. Instead of using a local file path in your hyperlink like: D:\Project_Local\workspace\.metadata\.plugins\org....


2

* THREAD TAKEN TO AWS FORUMS * http://forums.aws.amazon.com/thread.jspa?threadID=227061&tstart=0 * THREAD TAKEN TO AWS FORUMS * I had the same problem last week: My amazon server was somehow compromised. I received an abuse report from amazon stating my server was being used in a DDOS attack on a website. When I logged in I found an application /usr/...


2

If the offending domain is showing a copy of your site, then you certainly want to avoid letting it continue lest you end up getting penalised for duplicate content. This post on Stack Overflow appears to have a helpful answer for your case, since you know the domain that's the problem: There isn't a way to set this up as easily as you're able to with ...


1

At the end, ProxyMatch is the way to do it. <ProxyMatch "/cs/interni" > Order Deny,Allow Deny from all Allow from XXX.XXX.XXX.XXX </ProxyMatch> Thanks to all.


1

It should be as simple as: <Location "/cs/intranet"> require ip XXX.XXX.XXX.XXX </Location> The Upgrading to 2.4 from 2.2 - Apache HTTP Server Version 2.4 document gives a similar example of upgrading from: Order Deny,Allow Deny from all Allow from example.org to: Require host example.org because the default under 2.4 if it doesn't meet ...


1

I used the DNS Text Record method for Google site verification. I didn't know the DNS provider so I used Other, making the Text Record at A2 Hosting, and waiting for the DNS changes to propagate. All works now. Thanks for the replies.


1

Edit on http.conf <VirtualHost xxx.xxx.xxx.xxx:80> ServerName mail.domain.com RedirectPermanent / http://domain.com:port </VirtualHost>


1

This is possible but be aware that Tomcat and Apache would have to be accessed over different port so if someone wanted to access the Tomcat app they would have to access it using the Tomcat port which is port 8080 by default. If you don't want to have the port at the end of the domain (as http is port 80) then you would need to run two separate servers one ...


1

Problem solved. Someone at the tomcat mailing list pointed out that the "URIEncoding" had to be added to the AJP connector config. So, besides the change in the <Connector port="8080" tag in the Tomcat Server.xml you have to change this line <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" /> to this: <Connector port="8009" ...


1

Tomcat can be configured to password protect the contents of a web app. Here is a tutorial about setting it up. Create tomcat-users.xml similar to this: <?xml version='1.0' encoding='utf-8'?> <tomcat-users> <role rolename="tomcat"/> <user username="tomcat" password="tomcat" roles="tomcat"/> <user username="myname" password=...


1

I was able to finally resolve the issue by doing couple of things. Renamed the WAR file in my tomcat, in this case private-pages In my virtual hosts definition I changed ajp:// to reflect the above change. Here is virtual hosts file, <VirtualHost _default_:443> ServerAdmin webmaster@localhost ServerName localhost:443 ...


1

I suggest you use mod_rewrite to specify which directory gets the reverse proxy. Part of your problem is that the rewrite rules for WordPress are stealing requests from the proxy. If you use mod_rewrite for the proxy, then you can specify [L] to indicate that the proxy rule is the last rewrite rule and that the WordPress rewrite rules shouldn't be used. ...


1

I'm not aware of additional locations where you can have web.xml files for Tomcat. One thing that I do is run Tomcat as a secondary server on port 8080 behind Apache. I use mod_proxy to reverse proxy domains from Apache port 80 to Tomcat port 8080. This way I can put all the SSL onto Apache and configure Apache for the non-SSL redirects using virtual ...


Only top voted, non community-wiki answers of a minimum length are eligible