5

The following picks up on a fresh working LAMP installation under Red Hat 7 or clone (CentOS 7, Scientific Linux 7, Orcale 7, etc). Set Selinux to permissive for the installation. setenforce 0 First get the Mediawiki version you want from https://releases.wikimedia.org/mediawiki/ , at time of writing latest is https://releases.wikimedia.org/mediawiki/1.27/...


3

Use wgWhitelistRead in your LocalSettings.php configuration file.


3

I'm partly confused by your question, so I'll answer it the best I can. To set permissions on any file on a server (including php files) there's a couple of ways. If you have a web file manager interface, you can access that and set php file permissions through that. If you have direct FTP access to the server, you can use your FTP program to set php file ...


2

The problem you are having is related to case sensitivity on a unix filesystem, as well as an incorrect file extension. In your HTML you have the filename thisWeek.png however you are linking to thisweek.jpg, these are two different files. Fixing the filename causes the image to load. Watch your case as well. thisWeek.jpg and thisweek.jpg are different. ...


2

Apache's .htaccess files cannot be used to set unix file permissions. chmod is a command line tool for unix-like systems that is used to change the unix permissions of files on the filesystem. chmod is not an Apache or .htaccess construct, therefore chmod cannot be invoked through a .htaccess file - it can only be invoked by being executed on the server, ...


2

Permissions did not change by themselves, someone (or something) changed it. That could happen multiple ways: PHP Scripts changing permissions User changing permissions via FTP (chmod) The thing is, to change permissions for a file or folder, you need to have write permission on that folder. This allows you to remove permission from yourself (which ...


2

Well... I fixed it! But as it usually goes, I'm unsure of the exact thing that put it together. However, I will leave what I did over here, in hopes that it might help someone else in the future. From cPanel, I first changed my php version from 7.2 to 7.1. And it crashed my website. Therefore, I changed it back to 7.2, and voila! It simply works.


1

Have you checked if the folder has permissions to IIS user? Try testing with giving all permissions to everyone on the folder and check if files are accessible by your application. Then start restricting the permissions.


1

755 for folders and 644 for php and other files.


1

This is partially subjective and especially because your question lacks too many points of context like: which applications are using these certificates, which OS (based on your mention of 644 it seems you speak about Unix systems - in which case saying rw-r--r-- seems far more readable to me - but there are other OS out there), which level of security, etc. ...


1

It seems that the passage of a file through Mega makes it lose the group permissions and so in the server the www-data (the apache one) group doesn't have any permission and the pages just don't work. I haven't found a real solution to this problem but I changed the appoach to the problem itself and, since I use vim to edit files, I switched the editing of ...


1

This doesn't really have anything to do with Apache or server-side permissions, but more to do with how the browser resolves relative client-side URLs (according to RFC 3986). I'm assuming /html is your document root and index.html is accessed with an absolute URL of the form http://example.com/index.html. The browser (user-agent) must resolve all relative ...


1

"Option 1." Write a script. Something like create_account <student name> will do well. In the script do your create the directory(ies) and then make sure permissions are right. More or less, something like that: mkdir -p ~$1/public_html/{js,css,images} chown -R $1:www-data ~$1/public_html You could also create the student account at the same time. ...


1

I had a similar issue in the pass, and was able to resolve it by contacting Google directly. Google sent me a specific file I had to update on the website to prove that I really owned it, then they granted me admin access to the account and I could recover previous data.


1

Only run this command on your terminal chown -R username /var/www/html and then restart the vsftpd service by using below command sudo /etc/init.d/vsftpd restart


1

This drwxrwxrwx lets me know that beta is readable, writable and can be exercuted by all users of any groups, however what it doesn't tell me is that the files or folders within them folders use the same permissions. Please confirm that you have done chmod recursively using: sudo chmod 777 -R /var/www/beta If not, then it should resolve your issue.


1

As mentioned by master sensei closetnoc not all FTP connections allow that. In addition, as a Mac user I have noticed that not all FTP clients will allow editing. The best results I have gotten is using Fetch FTP client for Mac which there is also a Ubuntu version. This has allowed me to edit what is editable.


1

An explanation for the SELinux portion. I know next to nothing about mediawiki but use SELinux daily so I figured I would help explain what you are setting. I got the definitions from various man pages. httpd_can_network_connect_db (HTTPD Service) Allow HTTPD scripts and modules to network connect to databases. httpd_can_network_connect (HTTPD Service) ...


1

Looks like a no brainer, folder ownership! Try doing the following: sudo chown -R www-data:www-data /webroot


1

My question is what file permissions should I set for the files in this folder before I submit it to the hosting service in order to avoid problems with security, access, other things? There are many different types of hosting services, e.g.: your files won't have the same permissions on a shared hosting than in a dedicated server. It doesn't matter ...


1

I basically agree with Simon Hayters statement that if they gained shell access - unless they had limited shell access by injection into say a php application that was using shell_exec - I personally would start thinking about restoring the system from trusted sources. But then the question becomes - if you don't learn how they got in that time - how can ...


1

If they are able to login via your SHELL then its pretty much game over and as mentioned by @w3d Apache log files are least of your worries. Apache writes to log files directly, no one can view those logs unless they are stored within the hosting path. If security is a major concern then you should confirm that you use the following practices: Your SSH ...


1

... visitors of my website can't see the JSON file from it's URL, but that JavaScript file can access it? JavaScript is the wrong thing to be using if you're dealing with secure files. It sounds like you have javascript code that fetches special JSON code from the server you don't want guests to see, but if guests view source code and figure out the URL to ...


1

After much trial and error, it seems like the users need to be local administrators on the web server. Obviously, this a scenario that forces us to implement many other safeguards.


1

After search I see really a lot peoples with the same problem. Please check the OWNER of file, in my case the owner was ROOT. To solve the problem just do it: chown -R apache:apache /public_html/your_folder/sub_folder


1

The solution is to go to group * in the WikiAdmin - Permission manager and uncheck the Read under the Wiki column adjacent to the Namespace column mentioned in the question.


1

1.) Is there a (written) contractual agreement between you and your client? (a.) If so, what does the privacy/data usage/advertising-publishing clauses say you can do with the data? There data may be considered (proprietary information or covered under intellectual property law) of the country/state they are located. (b.) If not, then a contractual ...


1

KD - Good question. You should set permission 755 for all directories. Make sure that never set 777 permission for any folder/files. Also best thing is you set 755 for all word-press folders and 644 for all files. More details of permission : 777 – all can read, write and execute 644 - owner can modify file and everyone can read file


1

There is no default permission, but the MediaWiki extension TalkRight seems to do what you request. You use it by installing the extension and adding the following to LocalSettings.php. $wgGroupPermissions['user']['edit'] = false; // Start by preventing users from editing anything $wgGroupPermissions['user']['talk'] = true; // Let users edit talk pages $...


1

Drupal's built-in permission and publishing status system, along with rules can do this. First, et up a rule that creates an empty page for a user upon registration. Set the default permission for user to "edit own page", put not to create new pages. Also set default status for pages to be "unpublished" until published by a moderator. For an introduction ...


Only top voted, non community-wiki answers of a minimum length are eligible