3

I found reason of this issue: mod_autoindex uses mtime of index.html inside folder, not folder mtime. Reproduced on CentOS 6 with latest updates.


1

Apache is listing the modified date of the newest file inside the folder (not the folder itself).


1

The documentation states: [Last-modified] is only valid if the operating system and file system return appropriate stat() results. Since it is not working for your system, you can turn off the last-modified with: IndexOptions SuppressLastModified


Only top voted, non community-wiki answers of a minimum length are eligible