2

I just setup a domain with NearlyFreeSpeech, I've uploaded all the files, configured my settings to the best of my ability, but I still cannot access the site from it's respective URL.

A little about my configuration:

I changed the nameservers on my registrars side to the ones specified as the authoritative nameservers after creation. Respectively:

ns.phx1.nearlyfreespeech.net
ns.phx2.nearlyfreespeech.net 

I have an alias setup for www.example.com with the following DNS records:

example.com     NS  ns.phx1.nearlyfreespeech.net.
example.com     NS  ns.phx2.nearlyfreespeech.net.
www.example.com     CNAME   example.nfshost.com.

as well as SOA record.

If I navigate to the permanent link(example.nfshost.com) provided by NFS, the website loads correctly.

However it won't load when navigating to www.example.com. Maybe those NS records should be changed to www.example.com ?

Any help would be greatly appreciated!

Thanks, Stephen

  • How long have you waited? DNS takes anywhere from 1-72 hours to propagate. – closetnoc Oct 5 '16 at 14:55
  • It's been around 2.5 hours now. Should I check again tomorrow ? Does my config look legit ? – SGouws Oct 5 '16 at 14:57
  • At first blush, your settings seem okay. You will have to wait normally. One trick is to set your PC's network settings to use the DNS where your records exist. This allows for real-time testing. Cheers!! – closetnoc Oct 5 '16 at 15:00
2

As closetnoc recommended it is best to wait. Sometimes I have seen it happen within minutes and a good way to see how your site is propagating is to track it with:

https://www.whatsmydns.net/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.