0

I am getting "Missing: author, Missing: entry-title, Missing: updated" microformat error in Google's structured data testing tool.

I am showing the title in different way on my page that I cannot simple use <h1 class="entry-title">title...</h1>.

Is it possible to use this with in meta so that it (title) does not show on the page? Like we can do in Schema.org or Open Graph

<meta property="og:title" content="title..." />
<meta itemprop="headline" content="title..." />

The solution I can think of <span class="entry-title">title...</span> and then set display: none for span .entry-title{display: none;} in style sheet.

Just FYI, it is a WordPress blog site.

  • How do you show the title? And how is that title different from the title you want to use for the hEntry microformat? – unor Oct 4 '16 at 13:19
1

Google only wants you to mark up data that is visible to the user. See their Microformat quality guidelines:

Markup should not be used to hide content not visible to users in any form, since it might create a misleading or deceptive search experience.

If you want Google to use your marked up data, using meta elements or hidden elements is not allowed unless the same text appears visible to the user.

| improve this answer | |
  • I have change the page structure and now I am able to use standard option available: <h2><span class="entry-title" itemprop="name" > title... </span></h2> – atul Oct 13 '16 at 7:48
0

Use all class under a class <div class='hentry'><h1 class='entry-title'></h1> All other tag here similarly</div>

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.