2

Google Analytics seems to miss most of the clicks from Yandex. Is there anything to make them show up in Google Analytics?

  • By "miss" them you mean that the clicks don't get counted as "Organic Search" but rather appear in the "Referrals" report? – Stephen Ostermiller Oct 13 '16 at 16:24
  • It does not get accounted at all. – iwsnmw Oct 13 '16 at 17:52
1

Unfortunately Yandex is not one of the Default Search Engines in Googles list.

Fortunately there is a way to add Yanex and get the correct results.


Change your organic search traffic settings

This setting is managed in the admin settings of each property in your account. To add, edit, reorder, or remove search engines:

  1. Navigate to a property. If you're not in the settings menu, click Admin. Select the account and property you want to edit.
  2. From the property column, click Tracking Info then Organic Search Sources.
  3. Click +Add Search Engine.
  4. In the form, specify what the Domain Name Contains and the Query Parameter. You can also specify a Search Engine Name and what the Path Contains.
  5. Click Create

Click edit or delete to change or remove a search engine you’ve already added. To reorder the list, drag and drop the order of each row by using the mouse to grab the dots left of the search engine name.

You can learn more about it on Google's page : Customize organic search sources

| improve this answer | |
0

Google Analytics does track Yandex. It does not track it as search engine traffic, it reports it as referral traffic. Here is a screenshot of the Acquisition Referrals report for a Russian site. It shows Yandex as referrer #4:

enter image description here norcal johnny already posted a good answer about how to get GA to report it as organic search engine traffic instead.

| improve this answer | |
  • The weird thing is that I don't see them as referral as well, but I know that I get clicks from Yandex through server logs. – iwsnmw Oct 13 '16 at 18:05
  • Have you looked through multiple pages of the referrers? If it is just a couple in the server log, it might be from users that don't have JavaScript enabled or who have GA tracking blocked or disabled. You could also have a filter applied to your GA account that is discarding some data. Check to make sure there isn't a faulty filter. – Stephen Ostermiller Oct 13 '16 at 18:08
  • I checked my analytics without filters as well. The issue does not stem from them. The funny thing is, GA recognizes Yandex related traffic without "ru" TLD. – iwsnmw Oct 13 '16 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.