2

I have drive D: where my wamp server 2.2 was on for years and needed to move it to SSD drive F:. I proceeded like this:

  1. stopped all wamp services, exited aestryan menu
  2. copied wamp installation without www (too much junk) folder, from drive D: to drive F:
  3. created fresh www folder copied one WP install in there including original wamp index.php and loader-wizard.php
  4. used PowerGrep to replace all instances of D:/wamp to F:/wamp
  5. checked all ini/config files ,php, phpMyadmin, aliases, apache, the new drive letter is set.
  6. Double clicked wampmanager.exe located in F:/wamp (new drive)
  7. Server started, aestryan menu up, www Directory clicked it pulls correct folder F:\wamp\www
  8. went in my browser to localhost

It shows installations from drive D: (old drive)! What am I missing?

Solution: You MUST reinstallit the wamp, I was hoping on simple move but looks like wamp services map the localhost to the drive you originally installed the wamp on.

2
  • 1
    Did you delete the cache in your browser(s)? Simple, but often overlooked.
    – dan
    Sep 13, 2016 at 0:55
  • sure , did , dev tools cache disable on, checked in other browsers , check over remote locations. same . wamp services seems like hard mapping the localhost to drive letter
    – Benn
    Sep 13, 2016 at 8:46

1 Answer 1

4

For wamp 2.5 on Windows, use a text editor, e.g. notepad++ to edit c:\wamp\bin\apache\apache2.4.9\conf\httpd.conf

Change DocumentRoot "c:/wamp/www" to DocumentRoot "c:/my/new/path" (Note slash direction). This will change the location where files are served from (~Line 230).

Change <Directory "c:/wamp/www"> to <Directory "c:/my/new/path"> (Note slash direction). This applies permissions from the old directory to the new one (~Line 252).

Update: Is the F drive a data drive, a system drive or a partition? If it is not a system drive it is pretty much impossible to install the server there, since there is no "exe" support milieu on a non-system, or data, drive. If it is a system drive/partition, then you may indeed need to install it on F drive and just move over your files.

7
  • It sounds like the powergrep step (#4) should have caught that. Unless the grep wasn't done in the correct directory or was done case sensitive such that C: wouldn't have matched c:. Sep 13, 2016 at 4:32
  • Good eye or thought. I was thinking it's an incorrect path in general opposed to the drive being case sensitive and not being resolved with powergrep.. Sep 13, 2016 at 6:02
  • @norcaljohnny, everything is changed correctly , 150% sure, the issue seems in wamp services , looks like the install maps the localhost to the designated drive on install and you cant change it without uninstalling/reinstalling the wamp
    – Benn
    Sep 13, 2016 at 8:43
  • @Benn please see update. Sep 13, 2016 at 9:04
  • @norcaljohnny, it is a system drive , 2 drives , D is raptor, F is Agility SSD
    – Benn
    Sep 13, 2016 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.