2

I tried to add website URLs in Google Search Console by clicking on Fetch as Google. It removes the hash and shows that URL as the home page.

URL /mygharseva.prod/#/service/home-cleaning only shows as mygharseva.prod enter image description here

  • Have you tried "Fetch and Render" as opposed to just "Fetch"? The hash portion of the URL isn't actually sent to the server. The rendering JavaScript takes care of that portion. – Stephen Ostermiller Sep 3 '16 at 10:21
  • Yes, I tried with Fetch and Render but after submitted it goes to homepage and remove all url 's after hash. For that you can check attached screen shot. in my question summery – Swapnil Bijwe Sep 6 '16 at 9:32
  • From what I have read, Fetch as Google may just not support hash URLs at all. It does not support escaped fragment AJAX as asked about in this question: “Fetch as Google” doesn't find the HTML snapshot for my AJAX content – Stephen Ostermiller Sep 6 '16 at 10:57
  • I removed hash from url by using $locationProvider.html5Mode(true) and also add redirection on laravel side. This solved my issue, at least for now. – Swapnil Bijwe Sep 8 '16 at 16:41
  • I'm closing this because you indicate in the comments that you solved the problem without submitting an answer. – Stephen Ostermiller Jul 13 '17 at 15:34