1

I have a blog under wordpress.com and I inserted a fake image tag for analyzing visitors in widget like this:

<img src="http://www.my-cgi.com/cgi-bin/acclog.cgi?url=http://myblog.wordpress.com/">

But from June, 2016, seems like wordpress.com uses some cache and they convert the tag to like this:

<img src="https://i1.wp.com/www.my-cgi.com/cgi-bin/acclog.cgi">

Now I can't get the actual log of the visitors. Is there any way to insert image tag in my blog under wordpress.com without hitting cache?

1

It turned out that wordpress.com doesn't allow HTTP link. That's why it convert it to the cached contents with HTTPS. I moved my CGI to HTTPS enabled host and it works now.

0
<img src="<?php bloginfo('template_directory') ?>/image/location.png">

from a security perspective what your attempting to do by manipulating the URL parameter to get an external sites resource is not safe.

1
  • Thanks so much. I tried your tag but actually it has been escaped: &lt;img src=&quot;"&gt; Aug 16 '16 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.