1

My blog runs on the comicPress theme powered by Wordpress, on Altervista hosting service. I purchased the second level domain and therefore I aim customizing everything I need to.

I normally upload images through the menu Comics -> add comic -> upload media and then upload from my pc.

I want to change the size of images I upload there. So far I've been trying the following methods:

1)

I copy/pasted the script below in functions.php file and uploaded it but it didn't work:

@ini_set( 'upload_max_size' , '25M' );
@ini_set( 'post_max_size', '25M');
@ini_set( 'max_execution_time', '300' );

2)

then I tryed to configure a ftp server after having installed Filezilla. For I read, it is a requirement for accessing the root of my website and exploting a php.ini file (which will be create and saved there) which allows modifying the size for uploading. But while opening FileZilla server I got this error:

     FileZilla Server 0.9.58 beta
    Copyright 2001-2016 by Tim Kosse (tim.kosse@filezilla-project.org)
    https://filezilla-project.org/
    Connecting to server localhost:14147...
    Connected, waiting for authentication
    Logged on
    You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.
    Warning: FTP over TLS is not enabled, users cannot securely log in.

So what should I do for being able to upload bigger images?

1

Josip has given a great explanation. Here's other way you can do it. Locate wp-config.php file in your file manager.

There you can search using (Command + F), for this function:

define('WP_MEMORY_LIMIT','32M');

you can simply change it to 64M.

define('WP_MEMORY_LIMIT','64M');
0

There's a .htaccess also.

You can copy/paste this into your .htaccess file so you can modify your requirements.

php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 300
php_value max_input_time 300

if this doesn't help you, /or if you are on shared hosting, you need to contact your hosting provider so they can modify your upload sizes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.