Is there a simple way to do this without using "X-Robots-Tag: noarchive" and robots.txt ? Because in some shared hosting packages it is not possible to modify this kind of values.

I have came across with an alternative solution:

<meta name="robots" content="noindex">

This one also seems like not valid for svg files.


enter image description here

  • 2
    It looks like those are NOT SVG images that are getting indexed. Those are directories containing SVG images. You likely have "directory indexes" turned on. Turning off that feature will solve your problem. Jul 27, 2016 at 10:43
  • 1
    And on a host that doesn't permit .htaccess then you won't be able to turn "directory indexes" off - which falls back to Simon's answer - on a severely limited host you don't have a lot of options.
    – MrWhite
    Jul 27, 2016 at 11:32
  • 1
    @w3dk You can disable directory indexes by uploading an index.html file to each directory. I've put that into an answer. Jul 27, 2016 at 12:56

2 Answers 2


Your problem is not that SVG images are getting indexed. The items in your screenshot are image directories. If you visit those URLs you will likely see a list of files that are in the directories. Since they are image directories, the generated index page uses the word "svg".

This is a feature of web servers called "directory index". If you have .htaccess you can turn that off:

Options -Indexes 

Otherwise, you can upload an index.html file into each of those directories. The index.html file will take the place of the automatically generated directory listing. You could make the index.html file meta refresh to the home page, and put a noindex directive in it for good measure:

<!DOCTYPE html>
    <meta http-equiv="refresh" content="0; url=/">
    <meta name="robots" content="noindex">

I also want to point out that svg as a content keyword is not a problem that has to be fixed. Google shows the content keywords report so that you can check for spam. If you saw "viagra" or "escorts" on that list you would know your site has been hacked with unsavory content injected onto it.

As long as the keywords in the content keyword report are not spammy, you don't have to take any action because of it.


If you do not have access to noindex htaccess, noindex robots.txt or PHP X-Robots-Tag then sadly you don't have a lot of options. Only Google Search Appliance supports the use of googleoff and googleon.

Unless your interested in GSA the below method won't work, your only option is to ditch the current hosting and go with any decent hosting provider that will provide you with the necessary features and functions, that Google and Bing expect webmasters to have access to.

Excluding Unwanted Text from the Index

There may be Web pages that you want to suppress from search results when users search on certain words or phrases. For example, if a Web page consists of the text “the user conference page will be completed as soon as Jim returns from medical leave,” you might not want this page to appear in the results of a search on the terms “user conference.”

You can prevent this content from being indexed by using googleoff/googleon tags. By embedding googleon/googleoff tags with their flags in HTML documents, you can disable:

  • The indexing of a word or portion of a Web page
  • The indexing of anchor text
  • The use of text to create a snippet in search results

Example of googleoff

<!--googleoff: index-->

<h2>Inline SVG No Index</h2>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="-52 -53 100 100" stroke-width="2">
 <g fill="none">
  <ellipse stroke="#66899a" rx="6" ry="44"/>
  <ellipse stroke="#e1d85d" rx="6" ry="44" transform="rotate(-66)"/>
  <ellipse stroke="#80a3cf" rx="6" ry="44" transform="rotate(66)"/>
  <circle  stroke="#4b541f" r="44"/>
 <g fill="#66899a" stroke="white">
  <circle fill="#80a3cf" r="13"/>
  <circle cy="-44" r="9"/>
  <circle cx="-40" cy="18" r="9"/>
  <circle cx="40" cy="18" r="9"/>
<h2>External SVG No Index</h2>
<img src="example.svg" alt="example">

<!--googleon: index>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.