1

I have been trying to get this to work for hours. I have a WordPress multisite hosted on a shared server - but with a dedicated IP address for my WP installation, and my client sites are set up as subdomains inside of the WordPress network.

So a client might have a WordPress site called client.bigmultisite.com.

I want to use AWS Route 53 as the DNS service, and I want the client's own domain name to map to client.bigmultisite.com

In Route 53, I set up a CNAME that maps www.theclient.com to client.bigmultisite.com

I also set up an S3 bucket named theclient.com and statically redirected that to www.theclient.com

OK, at this point inside of Route 53 both www.theclient.com and theclient.com should end up redirecting to client.bigmultisite.com

The problem is that when I put either site into my browser (after flushing DNS, clearing history, trying different computers, etc) I always land on my hosting account "default cgi" page that says "sorry..."

Any insight as to what might be going on, would be appreciated.

  • Did you create these sites within your Apache server? All of them, sub-domains, www, etc. – closetnoc Jun 25 '16 at 18:29
  • no, WordPress handles all of that internally via some sort of rewrite logic. – C C Jun 25 '16 at 18:49
  • I do not believe that is possible. Apache always gets the request first. It has to. WP is not an application, it is a script and runs within Apache. For Apache, the site within the request header must exist or it will direct the request to the first site created. This sounds like what is going on in your scenario. – closetnoc Jun 25 '16 at 19:01
  • Then, how does WP multisite work with subdomains as network sites? Forget the DNS thing for a minute, in any basic WP multisite installation you can request a site called "somename.bigmultisite.com" and it will be served up without making any changes to Apache settings... – C C Jun 26 '16 at 1:21
  • Apache cannot recognize a site that it does not know about through it's configuration. This requires restarting Apache. It is possible that WP is making configuration changes and restarting Apache for you. It is possible, this is not working as expected. Keep in mind, that WP is a CGI script that runs in Apache. It is Apache that intercepts network HTTP requests by binding to a port - not WP. Apache runs WP when it receives an appropriate request. – closetnoc Jun 26 '16 at 4:43
1

All a CNAME record does is handle address resolution. In otherwords if client.bigmultisite.com has an A record of 1.1.1.1 if you then CNAME www.clientsite.com to client.bigmultisite.com the users browser will be given the IP of 1.1.1.1 to go to with the domain name of www.clientsitecom. What you would need to do it either have it running as the only site on the server so that all connections regardless of domain go to that site (default site in Apache) or you would have to go into the vhost record for the wordpress site and add each and every client domain as a host alias record. The first option is the most common as it is easier to maintain and does not require configuration changes every single time a new client is added.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.