I have a property A owned by Owner1 who delegates ownership to Owner2.

But that property is not visible to Owner2 on his webmaster console. Though Owner1 continues to see Owner2 as a verified owner (verified by delegation.)

What can be the issue? How can this be solved?


I've just had the same issue. The solution is to click "Add A Property" in the Webmaster Tools Search Console page. Even though someone else assigned you as an owner, you still have to add the property and type in the URL.

| improve this answer | |

This had been baffling us, but this worked perfectly:

  1. Went to the console
  2. Clicked "Add property"
  3. Typed in domain https://example.com
  4. It showed up immediately
| improve this answer | |
  • I am not being critical. I know you have the best of intentions! What you state is interesting. But how does that answer or relate to the question? It confuses me. Can you clarify so that others understand? Again, I am sure you are well intended. I just don't get it. Cheers!! – closetnoc Sep 7 '17 at 16:34

Happened to me as well. Fixed it by adding Owner 2 as a Full user first, then add as an Owner.

Start over.. 1) Remove Owner 2 from being an owner. 2) Add Owner 2 email as Full User 3) Add Owner 2 email as Owner

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.