6

I use Zoho.com as my email provider for me@mydomain.com. In Gmail, if an email does not use DKIM, a red padlock is shown next to the "From" address (I think). I investigated why emails from me@mydomain to my gmail account were showing the red padlock last night and discovered that several fields in my email headers listed the sender as secureserver.net (GoDaddy).

I do not use and am not signed up for GoDaddy email, not in Workspace and not an Office365 account.

The domain is managed through GoDaddy and I set the two MX records to point at mx.zoho.com and mx2.zoho.com. I followed Zoho's procedure for setting up DKIM last night and was able to send emails that did not show the red padlock.

Today, my emails are showing the red padlock again and inspecting the header shows several fields listing secureserver.net as the sender.

Why are my emails being captured and sent from secureserver.net and how do I stop it? I probably am completely misunderstanding something, but I got it to show the grey padlock for a few emails last night.

Correct Header:

Received: by 10.140.41.227 with SMTP id abcdefghijklmnop;
        Sun, 5 Jun 2016 22:22:57 -0700 (PDT)
X-Received: by 10.66.248.169 with SMTP id abcdefghijklmnop.13.1234567890;
        Sun, 05 Jun 2016 22:22:57 -0700 (PDT)
Return-Path: <MYUSERNAME@MYDOMAIN.com>
Received: from sender163-mail.zoho.com (sender163-mail.zoho.com. [74.201.84.163])
        by mx.google.com with ESMTPS id abcdefghijklmnop.106.2016.06.05.22.22.56
        for <MYGMAILACCT@gmail.com>
        (version=TLS1 cipher=ECDHE-RSA-AES128-SHA bits=128/128);
        Sun, 05 Jun 2016 22:22:57 -0700 (PDT)
Received-SPF: pass (google.com: domain of MYUSERNAME@MYDOMAIN.com designates 74.201.84.163 as permitted sender) client-ip=74.201.84.163;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of MYUSERNAME@MYDOMAIN.com designates 74.201.84.163 as permitted sender) smtp.mailfrom=MYUSERNAME@MYDOMAIN.com
Received: from mail-it0-f52.google.com (mail-it0-f52.google.com [209.85.214.52]) by mx.zohomail.com
    with SMTPS id 1234567890.1234567890; Sun, 5 Jun 2016 22:22:55 -0700 (PDT)
Received: by mail-it0-f52.google.com with SMTP id abcdefghijklmnop.1
        for <MYGMAILACCT@gmail.com>; Sun, 05 Jun 2016 22:22:54 -0700 (PDT)
Received: by 10.107.129.147 with HTTP; Sun, 5 Jun 2016 22:22:53 -0700 (PDT)

Bad Header:

Received: by 10.140.41.227 with SMTP id abcdefghijklmnop;
        Mon, 6 Jun 2016 09:36:42 -0700 (PDT)
X-Received: by 10.36.57.202 with SMTP id abcdefghijklmnop.5.123456789;
        Mon, 06 Jun 2016 09:36:42 -0700 (PDT)
Return-Path: <SRS0=P4k3=R6=MYDOMAIN.com=MYUSERNAME@bounce.secureserver.net>
Received: from p3plsmtp22-02.prod.phx3.secureserver.net (p3plsmtp22-02.prod.phx3.secureserver.net. [68.178.252.55])
        by mx.google.com with ESMTP id abcdefghijklmnop.103.2016.06.06.09.36.41
        for <MYGMAILACCT@gmail.com>;
        Mon, 06 Jun 2016 09:36:42 -0700 (PDT)
Received-SPF: pass (google.com: domain of SRS0=P4k3=R6=MYDOMAIN.com=MYUSERNAME@bounce.secureserver.net designates 68.178.252.55 as permitted sender) client-ip=68.178.252.55;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of SRS0=P4k3=R6=MYDOMAIN.com=MYUSERNAME@bounce.secureserver.net designates 68.178.252.55 as permitted sender) smtp.mailfrom=SRS0=P4k3=R6=MYDOMAIN.com=MYUSERNAME@bounce.secureserver.net
Received: (qmail 16233 invoked from network); 6 Jun 2016 16:36:41 -0000
Delivered-To: MYGMAILACCT@gmail.com
Received: (qmail 16230 invoked by uid 30297); 6 Jun 2016 16:36:41 -0000
Received: from unknown (HELO abcdefghijklmnop.prod.phx3.secureserver.net) ([68.178.252.55])
          (envelope-sender <MYUSERNAME@MYDOMAIN.com>)
          by abcdefghijklmnop.prod.phx3.secureserver.net (qmail-1.03) with SMTP
          for <MYGMAILACCT@gmail.com>; 6 Jun 2016 16:36:41 -0000
Received: from sender163-mail.zoho.com ([74.201.84.163])
    by abcdefghijklmnop.prod.phx3.secureserver.net with bizsmtp
    id abcdefghijklmnop; Mon, 06 Jun 2016 09:36:41 -0700
Received: from mail-io0-f174.google.com (mail-io0-f174.google.com [209.85.223.174]) by mx.zohomail.com
    with SMTPS id 1234567890.1234567890; Mon, 6 Jun 2016 09:36:40 -0700 (PDT)
Received: by mail-io0-f174.google.com with SMTP id abcdefghijklmnop.1
    for <MYUSERNAME@gmail.com>; Mon, 06 Jun 2016 09:36:40 -0700 (PDT)
  • 1
    I would look at your DNS records to see where things are pointing to because I remember once when I tried a CDN for my site, I had to change an entry in my DNS records so that the IP is that of the CDN. Perhaps a similar scenario happened to your email where the email entries of the DNS records point to secureserver.net? I'm not 100% sure but its something to look into. – Mike Jun 7 '16 at 1:52
  • Without the DNS info (you can edit that into the question), it sounds like you have Zoho CNAMED from a GoDaddy server. All of their servers use the generic "secureserver.net" mail host, even dedicated servers. There really shouldn't be any issues sending through secureserver.net to Gmail though as a lot of websites do the same. The red padlock you're referring to doesn't mean the email was marked as Spam, which is what DKIM would be helpful with, it means it was sent without TLS - see this from Google. – dan Jun 7 '16 at 1:52
  • 2
    Note also that although you might have set the MX records in your DNS to Zoho as indicated in their help doc here, that only specifies the mail server responsible for accepting email messages, not sending them. That would still be the job of the local SMTP mail server (i.e., secureserver.net if hosted on a GoDaddy server), which in email scripts is usually just referenced as localhost. – dan Jun 7 '16 at 2:10
  • 2
    @dan Thank you for those tips. Telling me that the MX records didn't matter let me focus on the Zoho settings. As I was examining that, I realized that for some of my tests I had been emailing my gmail account and for others I had been emailing a similar name, but at another domain I control. It turns out that it was the other domain that was receiving email through GoDaddy and then was being "incorrectly" forwarded to my gmail. It was all my mistake, but I was overwhelmed by how many options I could have screwed up and you guys cut my debugging scope in half! – J. Doe Jun 7 '16 at 18:19
  • No problem. Maybe you can put what helped into an answer below so it's clear for others in the future and accept it so the question will be considered closed. Thanks. – dan Jun 7 '16 at 23:51
1

I can not tell you have many people share similar problems with MX records on Godaddys CPanel/

Here is the simple fix, go into your Godaddy CPanel. Select MX records > Select Domain name in question > Select Remote Mail Exchanger.

That's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.