I configured Let's encrypt and Kloudsec for https://example.com as shown in these DNS settings:


Currently, I get a "Untrusted connection" error when accessing the website with www. How can I make the certificate working also for https://www.example.com (with www)?

  1. I think your DNS on your first row should have a "@" this symbol. This mean this is no "host" name as same as "www" (e.g. Normally, we see "mail" this word in front of "mail.helloworld.org". Here mail is the host name and the helloworld.org is your domain name. One domain can own many hosts. Do you want to use "hellowordl.org" as "www.helloworld.org" as an alias? If yes, you should set "@" in the name to be no host name. At lease, in my DNS working fine, it should be ok in yours.
  2. Do you use apache 2.4? For my case, I use it so that I explain my case to you. In addition, I use virtualhost to set up. There is a "site-available" directory and insides 000-default.conf and default-ssl.conf should be set up your alias domain, ServerAlias-"helloworld.org" and your ServerName "www.helloworld.org".) You may refer this document as below for more details. The more articles I recommend to google "apache document" this apache configuration page.


  1. About https: with Let's encrypt, so am I, this one is not easy to set up. But, there is a document. I am reading right now. I have some questions about its setting also. I think you may first refer these articles. The more pages I recommend to google "cerbot document", User Guide — Certbot 0.10.0.dev0 documentation.


Sorry about I am able to post only 2 links.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.