0

I would like to know why my two domains are mixed up in the search result. The two domains are https://vym.io and https://remotebase.io.

When I search 'remotebase', I see the title, and description of remotebase.io in the result, but it links to vym.io.

This is very strange because nowhere in the codebase of vym.io can I find any mention about remotebase. I also did a global search for 'vym' in remotebase.io's code and could not find anything.

In the Google Wwebmasters Tool's Search Analytics page for vym.io, I see all kinds of keywords related to remotebase.io but has nothing to do with vym.io. Also, in Google Analytics for RemoteBase, I can see links to vym.io showing up in the referrals.

Thing I have tried:

  1. Three days ago, I removed DNS settings for vym.io so that it does not resolve. This did not work and I restored the DNS.
  2. I compared <meta name="google-site-verification" ...> tag for both websites, and they are using different keys.

Additional info:

  • The websites are associated with different properties on google analytics.

I am out of ideas and this is very frustrating. Please help.

Edit

When I google site:vym.io, I get all the pages that belong to remotebase.io.

enter image description here

But when I click on them I go to vym.io and there is nothing on the page because the routes belong to remotebase.io.

Edit 2

These are nginx configs for each websites, hosted on separate servers.

remotebase.conf

map $http_upgrade $connection_upgrade {
  default upgrade;
  ''  close;
}

server {
  listen 80;

  server_name remotebase.io;
  return 301 https://remotebase.io$request_uri;
  access_log /var/log/nginx/remotebase-access.log;
  error_log /var/log/nginx/remoteabse-error.log;

  location / {
    proxy_pass   http://127.0.0.1:3000;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_http_version 1.1;
                proxy_set_header Upgrade $http_upgrade;
                proxy_set_header Connection $connection_upgrade;
  }

  server_name www.remotebase.io;
  return 301 $scheme://remotebase.io$request_uri;
}

vym.conf

map $http_upgrade $connection_upgrade {
    default upgrade;
    ''  close;
}

server {
    listen 80;

    server_name vym.io;
    access_log /var/log/nginx/vym.access.log;
    error_log /var/log/nginx/vym.error.log;

    location / {
        proxy_pass         http://127.0.0.1:5001;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection $connection_upgrade;
    }

  server_name www.vym.io;
  return 301 $scheme://vym.io$request_uri;
}
  • 1
    What do you see when you use Fetch as Google? Are there any crawl errors? You should be seeing what the Googlebot sees and will get indexed. From a cursory check on some of the URLs returned, there appears to be some redirect errors occurring. I'd check your vhost and .htaccess, which might help if you edit into the question. – dan Jun 6 '16 at 6:38
  • @dan I fetched and rendered as Google and I can see both sites fine. Could you point me to the redirect error? Also I edited the question to included nginx config I am using. – Sung Cho Jun 6 '16 at 8:34
  • @dan FYI I moved remotebase.io to a new server to see what happens. Will this help? – Sung Cho Jun 6 '16 at 10:49
  • Also I took down the app running on vym.io and deleted DNS settings for vym.io. It now does not resolve. This is fine because I only need to get remotebase.io to work. – Sung Cho Jun 6 '16 at 10:53
  • @dan I removed vym.io from google using search console yesterday, and now search queries 'site:remotebase.io' or 'remotebase' do not return remotebase.io in the result. The query 'remotebase.io' still returns a site with vym.io's meta tags but the correct link. Any ideas? – Sung Cho Jun 6 '16 at 19:08
0

Although I still do not know why it happened, I resolved the issue by moving remotebase.io to a new server. It took around 24 hours for the change to take affect.

I also removed vym.io from Google using webmaster tools. I do not know for sure if doing so helped at all.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.