2

I have an AWS basic free account (no support available), and need to connect to my ec2 instance (that's running Wordpress).

I did follow the steps to connect to my instance, but I got, from putty:

AWS: No supported authentication methods available (server sent: publickey)

The troubleshoot page didn't help.

I did try the users ec2-user, root and ubuntu (I believe the correct one is 'ec2-user') with no success.

There are some questions about this in stackoverflow and superuser, but none solved it for me. People talk about the public and private key files generated by putty, but I have only one file with the format:

PuTTY-User-Key-File-2: ssh-rsa
Encryption: none
Comment: imported-openssh-key
Public-Lines: 6
*[6 lines of data here]*
Private-Lines: 14
*[14 lines of data here]*
Private-MAC: a11ddb4e1a8f13bdd2c3efe3bb4714e426ed8e6a

Generated by puttygen without a key passphrase.

Someone suggested that the Home directory of my home PC OS may be encrypted (I'm using Windows 10). So I did move the .ppk file to root dir C:\, but the problem persist.

Any idea for how to connect to ec2 using ssh?

1

I have had this at times before and I have found that by adding a passphrase in puttygen it solved the issue for me. Don't know if this is by design with AWS forcing some description of passphrase or if it is a glitch with the certificate system they use but much of a muchness really.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.