The google mobile friendly test conveniently shows resources that could not be loaded...but it says nothing regarding how to go about fixing them.

I know this may be a broad question, but I'm just looking for some direction on where to go to figure this out. My issue is I don't know why it isn't loading, and I don't know if the resources in question are even relevant. Attached is an image with an example.

enter image description here

  • If you manually try and access a few one at a time, what error do you get??
    – closetnoc
    May 26, 2016 at 2:22
  • Excuse my ignorance, but what do you mean by access them?
    – CZorio
    May 26, 2016 at 13:13
  • Sorry. I mean type the resources URL into the browser directly and see what you get. It may work or at least give you a clue. Another option is to use something like Chrome's Developer Tools. One of the tabs is a network waterfall map that will list all the requests for all of the page/resources and any error code received.
    – closetnoc
    May 26, 2016 at 13:16
  • Is there a way of figuring out exactly which file is rendering the page? I used chrome tools, under the sources tab there is a file "(index)" which I believe is simply referencing the active file. That doesn't help me find what file to actually look into. I am trying to edit a theme and files like home, header, page, index etc are all just referencing deeply nested functions in files that are not the main functions or framework files. So I'm having a tough time figuring out where the scripts are acutally called.
    – CZorio
    May 27, 2016 at 14:03
  • @CZorio Have you got this resolved? I've been recently having this exact same issue and tried "Fetch as Google" and checked my robots.txt. I also checked with my host to see if anything is preventing Googlebot at their end. There doesn't seem any problem from my end. Aug 15, 2016 at 11:54

2 Answers 2


When the Google mobile friendly test says that a resource could not be loaded, it usually means that it is blocked by robots.txt. Check your robots.txt file and ensure that you don't disallow Googlebot from crawling these resources.

You can further diagnose the issue using the "Fetch as Google" feature in Google Search Console. Plug one of the resource URLs into this tool and Google would give more detailed information about why it would not be able to fetch it.

  • Did both. Fetch as google shows similar errors yet the page renders correctly (at least visually). Robots.txt has been reduced to allowing everything...
    – CZorio
    Jun 10, 2016 at 11:11
  • Make sure you fetch as Google with one of the blocked resources, not just the page they are on. It may take Google 24 hours to fetch your new robots file. Jun 10, 2016 at 12:46
  • @StephenOstermiller Same issue here. I tried Fetch as Google on one of the blocked resources but it's showing it as 'Complete'. I'm just unable to figure this out. Aug 15, 2016 at 12:00
  • @user1448031 could you edit the question to add a screen shot of the "fetch as google" for one of the resources? I've never seen it say just "complete" before. Aug 15, 2016 at 12:30
  • @StephenOstermiller Here is the screenshot: pasteboard.co/97hHnYB8n.jpg I've highlighted the css file that Mobile-Friendly Test was reporting as not loaded but Google Fetch is showing as Complete. Aug 15, 2016 at 23:41

If the Status says "Other error", there seems to be no clear reason for it but appears to happen for heavy sites loading a lot of resources. I had the same issue and after a lot of searching, this answer helped me.

To summarise it, it could just happen if a lot of resources are being loaded. As the link above states, it could actually mimic a real user on a slow mobile connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.