1

When I am checking Google indexing of my site and I saw that https version show another site.

What could be the problem? I never even bought SSL for my website. How do I fix this?

6
  • 1
    Your ssl configuration is incorrect, ask your host to fix it.
    – Abu Nooh
    Apr 6, 2016 at 11:19
  • Thanks Abu but I have not purchased ssl Apr 6, 2016 at 11:24
  • It's probably a shared one. Http(s) uses ssl. So tell your host to fix it. Are you on a shared host? Or does your uni have own tech admin? Ask either.
    – Abu Nooh
    Apr 6, 2016 at 11:29
  • Call your host. This is a configuration issue. It is also a quality of service issue. Any HTTPS request for your domain name should not receive a response.
    – closetnoc
    Apr 6, 2016 at 13:36
  • SSL is not configured properly on the server. Looking at the issue you are facing, every website which does not have a SSL certificate installed, will use other domain's SSL certificate. They will need to correctly configure pre_virtualhost_global.conf on the server.
    – MilesWeb
    Apr 6, 2016 at 13:57

2 Answers 2

1

This is because the server is a shared hosting environment. There are at least 300 other domains on your server with you. In such a case, most hosts will (for some reason) allow SSL on the main shared IP, which means the first person who gets an SSL gets all the traffic for any account also on the server. They do this on purpose even though there are ways to solve it with SNI. They want you to "upgrade" your hosting plan to one that comes with a dedicated IP and that will "fix it". Usually this is the 3rd level of shared hosting and will cost a bit more per month. The good news is that, usually, the host will give you a free cert with that package.

So unless you plan to get a SSL you have 2 options: Route your traffic for https/443 to normal http/80, or get a service like Cloudflare to sit as a front end, providing you with a free pseudo SSL even if you are unable to get one on the shared host.

1

Usually, web hosts install SSL certificate on dedicated IP address. But in your case, your web host has installed the SSL on shared IP of web server. The shared IP address is being used by the other hosted domains and hence when browser requests on port 443 the default website will be displayed.

127.0.0.1:443, website to display ==> website with SSL cert

127.0.0.1:80, HostHeader: avse.edu.vn, website to display ==> avse.edu.vn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.