27

I am tracking every member's geolocation (using db-ip) and everything is fine except mobile phones with the Chrome browser.

They always give me the result US Mountain View California ip:66.249.xxx.xxx. This is Google; I am 100% sure about it. But the person who visits the website is myself.

I am not even in the US; I am using a local GSM ISP.

Why does my IP address become one of the Google's IP addresses when I use my mobile with the Chrome browser?

47

You have Data Saver turned on in the settings of Google Chrome. It proxies all your HTTP (not HTTPS or incognito) traffic through an optimisation server at Google to make the pages smaller.

  • 5
    Fair to note that this is an opt in service and off by default. – David Mulder Apr 2 '16 at 7:32
  • 1
    @ozgur You probably got a small card at the bottom of your page at one point asking whether you wanted to turn it on. Considering it's a single tap overlaying the website you actually want to visit I guess it might be relatively easy to forget. And I think the preference is synced in your Chrome mobile settings from previous phones as well, but not sure about that last part. – David Mulder Apr 2 '16 at 9:38
  • 2
    @DavidMulder You might be right about that. But still, IMHO, it feels like default. People can forget about that they agreed for this service. Chrome should ask it at least once in a month for such a radical service (all my web surfing passes through Google servers). Actually I insist that Google should remind it to it's users. – ozgur Apr 2 '16 at 10:31
  • 2
    @ozgur: Well, Opera did this for years and years and nobody even blinked an eye (you couldn't even turn this off on mobile). I think it's a great feature, though somewhat useless as more and more of the web is using HTTPS (which isn't compressed or passed through Google as it would require compromising the security). – David Mulder Apr 2 '16 at 10:37
  • 1
    Looks off-by-default here on my devices. The official help doesn't state explicitly, but it does imply that it is off by default. – Michael Hampton Apr 2 '16 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.