1

I just checked HTML Improvement in Google Webmaster Tools (Search Console), and found that there are more than 150 pages with duplicate meta descriptions, and most of them are because of Facebook comment ID, like the following screenshot shows:

enter image description here

I have checked our database and we don't have any URLs with fb_comment_id. What should I do to fix these duplicate pages?

2

First make sure you have implemented canonical link tag properly.

Then configure URL Parameters for your website

Normally Google automatically handle URL parameter, but when some of pages have URL parameter and some of not, then Google need your advice to setup proper URL parameter in search console.

  • Hey, Goyllo! Thank you for your advice. I just checked the URL parameter in Search Console, and found that there are several parameters, and fb_comment_id is included, all of them are added by Google, I want to edit this parameter and select the URL I want to google crawl, but I can't find this choice. I only can make a choice that whether this parameter will change page content seen by the user. Google has blocked the function of selecting the URLs with parameter when setting up? Or I just don't have this permission? Thank you! – Vicky Mar 30 '16 at 3:24
  • May be Google is confuse because your Parameter ID is not same for all content. I have another solution, you can block that iframe content from search spider by using nofollow attribute with lazy load button, or by using robots.txt – Goyllo Mar 30 '16 at 5:52
-1

I think that the best choice here is to 'say' Google that you don't want this parameter to be indexed.

  • That would be a good solution, but without instructions on how to do so, this answer is not very good. It also appears to be the same thing Goyllo is suggesting when he says "configure URL Parameters". This answer doesn't add anything that other answers don't already have. – Stephen Ostermiller Mar 29 '16 at 17:38
  • Hey, Adam! Just like Stephen said, would you tell me how to tell Google that don't crawl the URLs with parameters. Because I did try to edit the parameter, but it only offers me a choice to decide whether this will change the content seen by users. How can I tell Google not to crawl these URLs? Thank you very much! – Vicky Mar 30 '16 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.