1

For some reason, my apache instances have stopped updating their conf files. I am able to reboot apache without any errors logged and apache will not recognize any changes.

I have gone so far as to actually try to break apache by removing the </VirtualHost> tag at the end of my .conf file and rebooting only to have it restart without error.

Next I fully removed all .conf files from the apache directory and restarted. Again apache started without error.

I have run updates, upgrades, rebooted multiple times.

How is this possible? How can apache reboot while having no conf files to work with? This is affecting multiple servers of mine, not just an individual one.

  • 1
    You said: For some reason, my apache instances have stopped updating their conf files. How is this done? Are you meaning that you use a control panel? Apache does not have a GUI except for Windows which is very limited that I am aware of. Your OS might be important too. – closetnoc Mar 11 '16 at 21:02
  • @closetnoc I don't use a control panel. I am manually editing all files through the linux terminal. As mentioned, when removing ALL .conf files including the 000-default.conf, apache will still restart without error. I find this behaviour very odd, almost unbelievable. Using Ubuntu server 14.04 LTS – Astupidmoose Mar 11 '16 at 21:47
  • The last I remember, Apache will not start without a .conf file. What is common for all of your machines that effect Apache?? Is it possible that it is using another .conf file somewhere? Are your sites still usable?? If so, this is a clue. – closetnoc Mar 12 '16 at 0:09
  • The main Apache config on Ubuntu is at /etc/apache2/apache.conf. It sounds like you're talking about vhost files, which are normally included by the main Apache config, I wouldn't expect deleting them to break Apache (although obviously it would make those vhosts no longer work). If there really is an issue, sudo apache2ctl configtest might give you some ideas. – Tim Fountain Mar 12 '16 at 0:17
  • And when you say "started without error" - are all your sites working as before?! – MrWhite Mar 12 '16 at 0:23
1

So I solved this after many hours of going back and forth. I wanted to post incase anyone has the same issue.

Problem: Somehow, all of the 000-default.conf symlinks within my /sites-enabled folder were replaced by the actual file 000-default.conf about 2 weeks ago. This happened on approx 90% of my servers, so the incident was not isolated.

Since the symlink was broken, there was no way for it to reflect the changes, and kept rebooting based on the config which was written in its place.

Solution:

  1. Remove the 000-default.conf from /etc/apache2/sites-enabled
  2. Re-enable the site using a2ensite 000-default.conf
  3. service apache2 restart

This seems to have fixed the issue. Hopefully it helps someone else down the road. I still have no idea what caused the symlink to be overwritten by the actual file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.