2

Recently I bought a new domain (example.com) and pointed it to my blogger account. My domain is working well.

But the problem is my sitemap contains the http://subdomain.blogspot.com which is the original blog that I actually created, instead of my custom domain.

Also when I copy a URL from my page, I'm getting http://subdomain.blogspot.com/some-xyz.

Why do URLs in my blog still have the blogspot subdomain in them, instead of my custom domain? I had tried changing templates, but this didn't resolve the issue.

Update:

I've reset the DNS to default and tried again. Now the issue is solved. It will be good if someone finds out what happened before so that this will not repeat again.

9
  • We'll have to know a little more information about what steps you took so far. Can you let us know what those were from here?
    – dan
    Commented Feb 28, 2016 at 7:08
  • purchased a domain. created CNAME "www" and Destination "ghs.google.com." Also entered A-records, in the "A" section. with following IPs. 216.239.32.21 216.239.34.21 216.239.36.21 216.239.38.21 Commented Feb 28, 2016 at 7:32
  • Just to clarify, you waited 24 hours (in step 11) and your custom domain is resolving to your blog, but you're concerned because links in your page still contain the subdomain instead of your custom domain?
    – dan
    Commented Feb 28, 2016 at 8:11
  • Yes. I don't have any problem with the resolving. I'm concerned with the links in the site. When I copy a link, I'm getting "subdomain.blogspot.com/post-url" instead of "example.com/post-url". To be specific I'm using a domain with ".in" extension Commented Feb 29, 2016 at 5:09
  • I further clarified this for you. The .in extension shouldn't be a factor if your domain is pointed to your Blogger site correctly and you followed the rest of the steps there. Note that we use example.com as a generic domain here since it's meant for that purpose, but users can see this from your comment above.
    – dan
    Commented Feb 29, 2016 at 7:16

1 Answer 1

1

As well as setting up the CNAME and ANAME records mentioned in the comments, you also need to publish your blog to the custom domain.

Go to the Settings > Basic tab, and follow the options under the Publishing section. This is where you may get the 2nd CNAME record that needs to be added for validation.

1
  • I've added the second Cname record also. Commented Mar 1, 2016 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.