Sometimes I visit the "fetch as google" section of the Google Search Console (webmaster tools). I then request to fetch and render the page, everything seems ok. I then attempt to the submit the page to index, and the usual dialog box as follows appears:

Choose submit method

You are submitting the following URL for indexing by Google: http://example.com

Recrawling happens a few minutes after you click Go. At that time, the content of your page is what Google will index. The page will be considered for indexing provided it meets our quality guidelines and avoids the use of noindex directives.

[option] Crawl only this URL

[option] Crawl this URL and its direct links

I wanted to select the last option, and I receive the following error message in light yellow text next to the cancel button (talk about bad user experience):

An error has occurred. Please try again later.

I also tried the other option in the same box, and I still receive the above message.

What would cause that message to appear or how would I fix it?

  • This may be a JS error. What browser are you using? Have you tried another??
    – closetnoc
    Feb 22, 2016 at 1:55
  • opera 11.60. This hasn't happened to me before, although ever since they updated their search analytics section, I had to switch to firefox 17 just to load that section Feb 22, 2016 at 2:44
  • well it worked in FF 17 plus there I had to verify I'm not a robot. Google is being a P.I.T.A. now. Feb 22, 2016 at 2:49
  • 1
    The PITA I know hate people that wear fur. I met at an exclusive cigar bar outside of D.C. with my humidor wedged just above Rush Linbaughs and to the left of Bill Cosby, a gorgeous blond that everyone was hitting on as she turned them down one by one. She liked me and was very interested. We went late into the night. I was interested too until she announced she was a member of PITA. I thought of my closet with sheep skin jackets, exotic sh*t kickers, leather hats, etc. People called me Montana back then. It was no surprise to many I am sure, but I just left her there. ;-)
    – closetnoc
    Feb 22, 2016 at 3:23
  • I recently heard about issues on this URL submitter in Google. I think there's just some glitches on the system. Have you tried using the fetch Google tool in the Search Console?
    – BryrDe
    Mar 13, 2018 at 5:14

1 Answer 1


This sometimes happens and very rarely will anyone be able to find out why it happened as Google is extremely secretive about its inner workings including with simple things like why you can't submit something to the index, instead simply saying something went wrong but has been fixed. The only thing you can really do in the mean time is close down your browser sessions, clear the cache, and try again. If it was something specific to a single server having an error then it should be no issue further, if there was a glitch in a recent code push then clearing the cache may give you a chance to get the corrected code when it is pushed out to the servers.

As with many things Google if something goes wrong wait a few hours and try again and often it will be fixed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.