2

I am trying to get mediaWiki to work on windows server 2012r2 using active directory as an intranet only site. I was successfully able to access the webpage on the server however when I try to connect to it on a network computer I am unable to. Any advice on what I can try?

  1. on the server i am able to access the webpage via: localhost/mywiki/ or by using the binding 192.168.1.10/mywiki (bound on port 80)

  2. on a network computer I try to access the same website via browser 192.168.1.10/mywiki but get "Webpage not available". However when using 192.168.1.10 I can access the default IIS webpage.

  3. I am fairly new to this so I apologize in advance. I disabled the firewalls on both server and workstation but that did not help. Teleneting to 192.168.1.10 80 returns a black screen. Any recommendations is greatly appreciated.

If it helps I followed these steps for the intranet website steps Configure IIS to Host a Simple Intranet Website Create a Web Site (IIS 7) (I'm using 8.5 but could not find a guide for this version)

  • You need to tell us more. For example: I was successfully able to access the webpage... How? When I try to connect to it on a network computer I am unable... How are you trying to connect? What have you tried? We may need some additional specific details; we will ask for them. Otherwise, without more details, there is nothing we can do but guess. – closetnoc Jan 14 '16 at 17:12
  • @JohnConde Do we have enough details to re-open?? Cheers! – closetnoc Jan 14 '16 at 19:21
  • I will be going away for a while, but you have given us something to at least begin asking questions. I will up-vote to give your question some attention and asked John if we have enough to reopen. I do not know mediaWiki or IIS at all, but there are a few here that do know these systems rather well. – closetnoc Jan 14 '16 at 19:23
1

Note that Webpage not Available is not necessarily the same as page not found. I am guessing that it is finding the site but you are having another site issue.

First try to add a simple hello world html file to the site and see if you can browse that file. Then you can confirm if you can hit the site.

Next, in the site, you can set customErrors to Off in the web.config of the website so that IIS will give you the actual error you are producing (if any).

Active directory can be causing an issue for authentication. Which is why it appears to work when you are logged on locally. You can try to set the site to allow anonymous and see if it browses from the other computer.

If that still doesn't give you any information, I am thinking that something is crashing the site so check the app pool and find out if it stopped because of an error.

Then there is always checking the event logs to see if there are any clues.

I hope these steps help.

-1

Thanks everyone for the help. Turns out I needed to specify a local ip in the localsettings file.

$wgServer = [local host ip];

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.