2

I have deployed an app on heroku - http://appsparkler.heroku.com and created a custom domain for it - www.appsparkler.com

Then, from goDaddy, where I have purchased this domain name appsparkler.com, I forward with masking to http://appsparkler.heroku.com and redirect 301 (Permanent). Screenshot

enter image description here

Then, I made changes to the DNS ZONE FILE where I added CNAME and A Host as per a blog I found on the internet.

enter image description here

enter image description here

This works fine and when I visit www.appsparkler.com I am redirected with masking and can also visit the various links with the URL changing to the link I click on. However, when I browse the webapp with appsparkler.com i.e. without the www, I can go to the various links; however, the links in the address bar don't get updated. For comparision, I have added screenshot of address bar when on home page, first with www.appsparkler.com and then with appsparkler.com. We can see that /home doesn't reflect in second one. Moreover, even the favicon.ico doesn't appear in the second one (without www) as we can see...

enter image description here

enter image description here

I have tried searching a lot and also tried trial and errors with different settings and looked for solutions on the web and nothing worked.

Please help. Thank you in advance.

  • 1
    I was going to suggest that perhaps the problem was the "with masking" bit? (I would have thought example.com should just be an external redirect to www.example.com and then the CNAME record in DNS directs the request to the heroku server?) But you appear to have already solved it - how did you solve it? – MrWhite Jan 4 '16 at 23:41
  • Please check the answer in the answer section. I figured it after re-configuring as per instructions on lifesforlearning.com/heroku-with-godaddy. And also what you have suggested in the comment is what fixed it. – Akash Jan 5 '16 at 0:42
1

Reference http://lifesforlearning.com/heroku-with-godaddy/

In the FORWARD AND MASKING section (which is under SETTINGS >> Forwarding), I was forward(ing) with masking (as you can see in the screenshot in the question above) to the herokuapp >> http://appsparkler.herokuapp.com. I changed that to forward(without masking) to http://www.appsparkler.com as you can see in the screenshot below.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.