3

I recently upgraded my debian installation from wheezy to jessie. Now I get only blank pages when accessing phpmyadmin.

The apache log says:

Fatal error: Call to undefined function __() in /usr/share/phpmyadmin/libraries/core.lib.php on line 235

I already tried purging (+ deleting all config in /etc/apache2 and /etc/php5 /etc/phpmyadmin) and reinstalling all related packages (phpmyadmin, php5, apache2)...

I found a similar thread that suggested to check the write permission on the php sessions directory:

ls -lah /var/lib/php5/sessions/ drwx-wx-wt 2 root root 4,0K Jan 3 19:09 .

looks ok to me, but to make sure I tried chmod +rwX on the whole thing - still no luck.

I'm a bit out of my wits... What else can I try without starting from scratch with a clean new debian installation? Did I miss any folders or config files on my cleaning efforts?

BTW: First, I got the following error:

PHP Fatal error: require_once(): Failed opening required '/usr/share/php/php-gettext/gettext.inc' (include_path='.') in /usr/share/phpmyadmin/libraries/select_lang.lib.php on line 463

The file mentioned in this message existed and was readable for all users. I then tried:

  • uninstalling and reinstalling all packages with "php" in their names (including phpmyadmin)
  • restoring default php configuration (delete /etc/php5/apache2/php.ini file)
  • using the apache default site config (000-default.conf)

... but I still got this error. Then I purged everything and got the error I first mentioned above.

  • Much of the things you have done have nothing to do with your errors. The issue is phpmyadmin. Not Apache. Not PHP. Not what web site configuration file you use. Reread the errors again carefully and slowly. You will see what I mean. It is Phpmyadmin alone. Focus there. And if someone advises reinstalling PHP, Apache, changing your Apache configuration, dancing with a chicken, sacrificing your first born, blowing up the capitol, STOP!! If your lights go out, it is not because the toilet is stopped up (although that could be a problem too). Focus. – closetnoc Jan 3 '16 at 19:35
  • 1
    Uh, sorry, that didn't exactly help. You want to say there is an error in the phpmyadmin package or what? As far as I know I reset everything phpmyadmin-related to default. – Bytemaster Jan 3 '16 at 20:51
  • Is PHP compiled with gettext support? __() is a gettext function, which your previous error also references. – MrWhite Jan 3 '16 at 22:58
  • Yes. I am saying that your problem is Phpmyadmin. I would be making sure that PHP and anything else is up to date since you already have upgraded at least part of your system. But yes. The code fault is in Phpmyadmin. Now here is something that is often missed. If you uninstall phpmyadmin again for any reason or decide to install it again, make sure it is literally gone before you install again. Some installs act like upgrades and will miss some conditions. It would better to wipe it fully and start over. Otherwise, trace the errors down to what is missing or broken and fix. – closetnoc Jan 4 '16 at 1:44
  • What version of PHP are you using? – DisgruntledGoat Jan 5 '16 at 15:57
1

What solved this issue for me was to search and purge every php-related package (now also including php-gettext and so on). After reinstalling the packets libapache2-mod-php5 php5 php5-mysql php-gettext php5-mcrypt php5-readline php5-gd php5-json and finally phpmyadmin, I could access phpmyadmin again, restore my website configurations and everything seems to run fine so far...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.