1

I need some help asap. I had some problems with my icon fonts and found out, it's because of the CDN and "cross domain". So I thought, I should try to deactivate my CDN and look what happens.... BAD IDEA!!!

There were different error sites and so I turn on the CDN again. I know that I have to wait up to 48 hours until everything should work. But nothings worked and I have clients who pay for my service on this site.

My site works with WordPress but I can't even login because the wp-admin page doesn't appear.

The problem is, the site appears but without any JavaScript and CSS. With the "Developer Tools" I checked my HTML code and found out, every link to CSS or JavaScript is wrong. I use SSL everywhere but it shows HTTP instead of HTTPS. And sometimes there is even no http: or https: (see below).

  • script type=text/rocketscript data-rocketsrc=//www.domain
  • script type=text/rocketscript data-rocketsrc=http://www.domain

I already switch of the rocket loader of CloudFlare and upload my local header.php, but nothing works. I type the "s" of https manually with the console to check, if it would work... and it did.

So how can I get rid of this rocketscript and add HTTPS everywhere instead of HTTP?

  • A URL without http: or https: is simply a protocol relative URL and is often preferable when you have mixed content. – MrWhite Jan 3 '16 at 0:08
1

The issues with icon fonts are related to CORS (check out the article What is CORS?). You should have the option to add the appropriate HTTP headers to get rid of that problem. Here's an example of the HTTP header access-control-allow-origin:enter image description here

The missing http(s) is not a problem. When you just use "//" either http:// or https:// will be used automatically based on your site setup.

0

Your situation is bad I must say. But still, you can be able to make some "attempts" to solve it. I suggest you use your backup files and restore your site to its original state. But if you don't have any backups, he try the below.

Firstly, activate your site on Cloudflare again. Try to use the default settings and see if your site will work again. Try to ignore the images and icon breaking since that is a common issue, and which we will solve later and automatically.

Once you have your site working with original settings, now you can try to switch back to your host servers. But please note, if you had tampered with the default settings, then you can revert them to what many recommend. I think that doing so can help restore your site back otherwise, you will need a back up to do it. Settings you should change include page rules, speed, networks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.