2

I have recently converted a pre-2.4 configuration to Apache's new authorisation configuration but ran into a problem/misunderstanding concerning more than one RequireAll block.

What I am basically trying to do is to block certain IP addresses, however, a few of them should still have access to one particular file.

I had the following configuration but it seems the second block overrides the first one.

<RequireAll>
  Require all granted
  Require not ip 1.2.3.4
</RequireAll>

<FilesMatch "?!^EXCLUDED-FILE">
  <RequireAll>
    Require all granted
    Require not ip 5.6.7.8
  </RequireAll>
</FilesMatch>

Any idea what I got wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.