I have wordpress installed on an Ubuntu web server. I installed wordpress no problem then followed this guide to add https http://www.liberiangeek.net/2014/10/install-wordpress-self-signed-ssl-apache2-ubuntu-14-04/

my site loads https for the home page and admin page, but all other pages give me a 404 if i try to load them with https.

Maybe i did something wrong along the way but I'm not sure, I've tried following a few guides, editing my wordpress config file to enable ssl, editing the httpaccess file, editing the 000-default.conf and default-ssl.conf but nothing seems to work, it still kills pages like a categories page or a post.

Im not sure if this has anything to do with it but this is an intranet site, and when I set the dns so it has a domain (actually subdomain) it.name.com basically, but whenever i load the site with the domain name it instantly redirects to the IP address, but still loads. also this is a wordpress multisite and I understand somethings are different.

1 Answer 1


Most likely because you have not installed the WordPress .htaccess file as required for search engine friendly urls (permalinks). If your using a VPS or DEDICATED server then you will need to ensure that you have mod_rewrite enabled and configured correctly, if your using shared hosting then the likelihood is that it's already enabled.

Enabling Rewrite

  1. sudo a2enmod rewrite - Installs mod_rewrite
  2. sudo service apache2 restart - Restarts Apache
  3. nano example.conf Edit your SITE conf file
  4. AllowOverride All Change none to all

Creating a WordPress .htaccess file

In the root path of your website create a blank file called .htaccess and fill it with the following WordPress defaults:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.