1

I'm having some trouble with my Facebook sharing on my site www.letitgo.ca . I'm finding that when the site is shared, I get a blank thumbnail where an image should be in my facebook feed. From googling around it looks like others have had similar problems as well, I've looked at some solutions others have used but they either haven't worked for me or I haven't been technically savvy enough to implement them properly.

I'm using wordpress + sumome app for sharing, however I've experienced the same behavior with different sharing apps. I've noticed something funky in the code:

<meta property="og:image" content="http://ia.media-letitgo.ca/images/passage.jpg"/> 
<title>letitgo.ca - releasing into clarity and possibility</title>

<!-- This site is optimized with the Yoast WordPress SEO plugin v2.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="releasing into clarity and possibility"/>
<link rel="canonical" href="http://www.letitgo.ca" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:title" content="letitgo" />
<meta property="og:description" content="Let go and release into clarity and possibility" />
<meta property="og:url" content="http://www.letitgo.ca" />
<meta property="og:site_name" content="letitgo.ca" />
<meta property="og:image" content="http://www.letitgo.ca/wp-content/uploads/2015/03/passage.jpg" />

The first og:image tag links to an image that doesn't seem to render. I think the first tag might be overwriting the second (which works), but I can't for the life of me find out how that tag is being inserted, I've scoured WPs options but cannot figure out what's responsible. Also of note, when I run the site through facebooks graph API I get this:

{
   "error": {
      "message": "An access token is required to request this resource.",
      "type": "OAuthException",
      "code": 104,
      "fbtrace_id": "AoZ4gOp/amf"
   }
}

Which I'm not sure what to make of. If anyone has any ideas please let me know!

  • Yes it seems Facebook is grabbing the 1st og:image property, so you have to track down what is inserting that line. I checked the theme and it's not that, so it has to be one of your plugins. Does ia.media-letitgo.ca mean anything to you? – johnh10 Oct 29 '15 at 14:03
  • It looks ok in the Open Graph debugger, but doesn't actually show in the newsfeed when shared. Weird. I noticed this in the OG debugger: ![enter image description here](i.stack.imgur.com/Ug032.jpg) The red squares link to the ia-media image that doesn't exist. I am at a total loss of what part of wordpress is inserting that first og:image tag into the html! – Spence Nov 13 '15 at 15:47
1

It seems that everything is ok with your homepage .

Try to use Open Graph Object Debugger https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.letitgo.ca%2F

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy