I have WHMCS installed on a sub domain and I have followed the install steps listed on the WHMCS knowledgeable, including:

When complete, delete the install folder from your web server and CHMOD the configuration.php file back to 644. Required file & folders permissions

  • /configuration.php CHMOD 400 Readable
  • /attachments CHMOD 777 Writeable
  • /downloads CHMOD 777 Writeable
  • /templates_c CHMOD 777 Writeable

The above applies unless your php is suPHP or PHPSuExec. If using DSO as your php handler, you must use 644 permissions.

Which does not seem to make sense.

Recently, when I try to access the site, I get the following message:

Security Warning

The install folder needs to be deleted for security reasons before using WHMCS.

I have deleted the folder but every day it reappears. I have emailed support and their reply was:

I recommend checking with your systems administrator to see if you have any functionality on your server which would restore folders. They would be in the best position to review and investigate this with you.

I am the webmaster and when I spoke to my hosting company, they responded:

We are also unsure how the directory re-appears

I have also searched and read a number of forums e.g. Install Page displays after installation and delete of install folder, and the only answer I get is to delete the folder or contact WHMCS support.

How can I stop WHMCS install folder from reinstalling every day?

  • Please include whom the user and group ownership of this folder belongs to, the folder name, the whereabouts of this folder (full path, not virtual) and the full time stamp of the folder. Oct 20, 2015 at 11:03

1 Answer 1


I'm not sure what's causing the problem, but you can probably work around it by adding an empty install directory, and setting the permissions to read-only.


rm -rf install
mkdir install
chmod 400 install

This will remove write access from the directory, so the files won't get recreated.

It's definitely a hack, but will hopefully prevent the issues you're having.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.