I've uploaded WordPress to my GoDaddy and when I go to example.com/wp-login.php to login page looks bare. I would expect to see the styled default WordPress login page and secondly when pressing submit it causes a 500 internal server error, because the page is redirect to example.com/wordpress/wp-login.php, which is basically looking into /wordpress/ and not the root.

I've tried looking for this /wordpress/ directory in wp_config as well as used interconnectit to replace any example.com/wordpress/ entries with just example.com, but it didn't find any such entries in the database either.

I've also tried messing with .htaccess, such as removing '/wordpress/' from it, but that causes just more trouble. I've no idea where this redirect to /wordpress/ comes from, anyone?

1 Answer 1


WordPress by default will uncompress to /wordpress/ from the downloadable archive, this is because the compressed file contains the parent directory labelled wordpress. If you then run the installer from this folder it will automatically set the path to this location within the SQL. Unless your using a SEO plugin that controls the SEF URLS then there is only several ways that WordPress will redirect, these are: SQL, .HTACCESS and WP-CONFIG.PHP


Unlike older versions of Joomla and other other content management systems by default WordPress does not set the URL path, unless you edit this file and change the defined path. The define untouched looks like:

if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');


WordPress by default does not control the install path using the htaccess file, a default htaccess should look exactly like this:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]


WordPress by default on install will add two entries into your SQL database:

  • wp-options
    • option_name: siteurl option_value: http://www.example.com
    • option_name: home option_value: http://www.example.com

You shouldn't need to edit the database directly, as WordPress allows you to change the siteurl, and home path directly in your WordPress.

  • Navigate to http://www.example.com/wordpress/wp-login.php
  • Login to the administration dashboard
  • Click Settings
  • Click General
  • Change WordPress Address (URL)
  • Change Site Address (URL)
  • Click Save

Your settings should look something like this:

WordPress General Settings

If for whatever reason you can't login then use phpMyAdmin to change the values outside of the WordPress environment.

  • Great info; Problem is I deleted the wordpress folder, so there's no site.com/wordpress/wp-login.php, only site.com/wp-login.php. I only have the wp-admin, wp-content and wp-includes folders plus the individual files that share their wordpress directory inside root. I'd learnt that these should be enough to get wordpress published as www.mysite.com (without /wordpress after it), but again seems wordpress insists on adding /wordpress. Also, what should "if ( !defined('ABSPATH') ) define('ABSPATH', dirname(FILE) . '/');" contain? Oct 16, 2015 at 21:43
  • seems my hosting plan will expire before i figure out wordpress on godaddy Btw, stackexchange removed the underscores around FILE above, and turned it bold. Oct 16, 2015 at 21:55
  • Oh and my .htaccess includes /wordpress/ after RewriteBase and RewriteRule, but as i mentioned removing it causes 404 or other problems. Oct 16, 2015 at 22:53
  • seems i should be redirected to wp-admin.php after login in, but am redirected to /wordpress/wp-login.php which yields a 500 error. Typing in site.com/wordpress/wp-admin.php also causes a 500 error, even if removing /wordpress before it. Oct 16, 2015 at 23:17
  • Your only get 500 errors from the .htaccess, so delete that and contact your host. In regards of the install path just use phpMyAdmin and edit the SQL as suggested. Then ensure you don't have a folder called /wordpress/. Oct 17, 2015 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.