0

I'm trying to exclude my top-level page and certain section pages from a custom report using the exclude filter. It works for a single pattern (i.e. \news), but when I try multiple patterns separated by pipes as described here (i.e. \news|\blog|\catvideos), none of the patterns are filtered. I would create a filter for each pattern but I need more filters than the maximum allowed by analytics. Is there something wrong with my syntax? Any advice would be appreciated.

0

Here's a solution I found. Instead of using the "exact" match setting for the filter pattern, I switched to "regex". The regex string to filter the multiple-pattern string in the example above would be ^\/news$|^\/blog$|^\/catvideos$.

-1

Select "Matching Regex" instead of "containing" while filtration. And then simply enter the pattern you are entering i.e. (\news|\blog)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.